Permalink
Browse files

Upgrading to 3.1

  • Loading branch information...
1 parent 964ee25 commit 7787354181203849524c2b580737ccccf7fe1f1e @arunagw arunagw committed Sep 14, 2011
Showing with 29 additions and 10 deletions.
  1. +18 −7 Gemfile
  2. +11 −3 config/application.rb
View
25 Gemfile
@@ -1,16 +1,27 @@
source :rubygems
-gem 'rails', '~> 3.1.0.rc5'
+gem 'rails', '3.1.0'
+
+# Bundle edge Rails instead:
+# gem 'rails', :git => 'git://github.com/rails/rails.git'
+
gem 'mysql2'
+
+
+# Gems used only for assets and not required
+# in production environments by default.
+group :assets do
+ gem 'sass-rails', " ~> 3.1.0"
+ gem 'coffee-rails', "~> 3.1.0"
+ gem 'uglifier'
+end
+
gem 'jquery-rails'
-gem 'uglifier'
-gem 'rake', '~> 0.8.7'
gem 'high_voltage', '~> 0.9'
-gem 'jquery-rails'
+
gem 'kaminari', '~> 0.12.4'
-gem 'sass-rails', :git => 'https://github.com/rails/sass-rails.git', :ref => 'eee12e2e0bbfca56d458c82df47213e130ef5830'
-gem 'compass', :git => 'https://github.com/chriseppstein/compass.git', :branch => 'rails31'
+gem "compass", "~> 0.11.5"
gem 'simple_form', '~> 1.4.0'
gem 'friendly_id', '~> 3.2.1'
@@ -34,4 +45,4 @@ group :test do
gem 'valid_attribute'
gem 'launchy'
gem 'simple-rss', '~> 1.2.3'
-end
+end
View
14 config/application.rb
@@ -2,9 +2,13 @@
require 'rails/all'
-# If you have a Gemfile, require the gems listed there, including any gems
-# you've limited to :test, :development, or :production.
-Bundler.require(:default, Rails.env) if defined?(Bundler)
+if defined?(Bundler)
+ # If you precompile assets before deploying to production, use this line
+
+ Bundler.require *Rails.groups(:assets => %w(development test))
+ # If you want your assets lazily compiled in production, use this line
+ # Bundler.require(:default, :assets, Rails.env)
+end
module BangaloreRuby
class Application < Rails::Application
@@ -41,6 +45,10 @@ class Application < Rails::Application
# Enable the asset pipeline
config.assets.enabled = true
+
+ # Version of your assets, change this if you want to expire all your assets
+ config.assets.version = '1.0'
+
config.sass.load_paths ||= []
config.sass.load_paths << "#{Gem.loaded_specs['compass'].full_gem_path}/frameworks/compass/stylesheets"
end

0 comments on commit 7787354

Please sign in to comment.