jruby 1.7.2 cannot install pry-exception_explorer gem #32

Closed
bzb2 opened this Issue Feb 28, 2013 · 2 comments

2 participants

@bzb2

using jruby-1.7.2
running on ubuntu 12.04 64bit

jruby -S gem install pry-exception_explorer

Building native extensions. This could take a while...
ERROR: Error installing pry-exception_explorer:
ERROR: Failed to build gem native extension.

    /opt/jruby-1.7.2/bin/jruby extconf.rb

NotImplementedError: C extension support is not enabled. Pass -Xcext.enabled=true to JRuby or set JRUBY_OPTS or modify .jrubyrc to enable.

(root) at /opt/jruby-1.7.2/lib/ruby/shared/mkmf.rb:8
require at org/jruby/RubyKernel.java:1027
(root) at /opt/jruby-1.7.2/lib/ruby/shared/rubygems/custom_require.rb:1
(root) at extconf.rb:19

Gem files will remain installed in /opt/jruby-1.7.2/lib/ruby/gems/shared/gems/binding_of_caller-0.7.1 for inspection.
Results logged to /opt/jruby-1.7.2/lib/ruby/gems/shared/gems/binding_of_caller-0.7.1/ext/binding_of_caller/gem_make.out

cat /opt/jruby-1.7.2/lib/ruby/gems/shared/gems/binding_of_caller-0.7.1/ext/binding_of_caller/gem_make.out

/opt/jruby-1.7.2/bin/jruby extconf.rb
NotImplementedError: C extension support is not enabled. Pass -Xcext.enabled=true to JRuby or set JRUBY_OPTS or modify .jrubyrc to enable.

(root) at /opt/jruby-1.7.2/lib/ruby/shared/mkmf.rb:8
require at org/jruby/RubyKernel.java:1027
(root) at /opt/jruby-1.7.2/lib/ruby/shared/rubygems/custom_require.rb:1
(root) at extconf.rb:19

@banister
Owner

The README states only MRI is supported, and the project page is found here: https://github.com/pry/pry-exception_explorer

@banister banister closed this Feb 28, 2013
@banister
Owner

PLEASE read the READMEs in future, you've just filed 3 issues that did not need to be filed if you had done your reading :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment