Permalink
Browse files

version 0.2.3 release

  • Loading branch information...
1 parent c1d6387 commit b8726e0369cced022695407184b7fa619caaa8b1 @banister committed Dec 1, 2012
Showing with 33 additions and 4 deletions.
  1. +2 −3 lib/pry-note/commands.rb
  2. +1 −1 lib/pry-note/version.rb
  3. +30 −0 pry-note.gemspec
@@ -185,8 +185,7 @@ def create_note_output(name, verbose=false)
raise Pry::CommandError, "Please specify the name of a method or class." if !name
if !notes.has_key?(co_name)
- output.puts "No notes saved for #{text.bold(co_name)}"
- return
+ raise Pry::CommandError, "No notes saved for #{text.bold(co_name)}"
end
out = ""
@@ -196,7 +195,7 @@ def create_note_output(name, verbose=false)
out << Pry::Code.new(code_object.source, code_object.source_line).with_line_numbers.to_s + "\n"
end
notes[code_object_name(code_object)].each_with_index do |note, index|
- out << "\nNote #{text.bold((index + 1).to_s)}: #{note}\n"
+ out << "\nNote #{text.bold((index + 1).to_s)}: #{note}"
end
out
@@ -1,3 +1,3 @@
module PryNote
- VERSION = "0.2.2"
+ VERSION = "0.2.3"
end
View
@@ -0,0 +1,30 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = "pry-note"
+ s.version = "0.2.3"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["John Mair (banisterfiend)"]
+ s.date = "2012-12-01"
+ s.description = "Ease refactoring and exploration by attaching notes to methods and classes in Pry"
+ s.email = "jrmair@gmail.com"
+ s.files = ["Rakefile", "lib/pry-note.rb", "lib/pry-note/commands.rb", "lib/pry-note/hooks.rb", "lib/pry-note/version.rb", "test/helper.rb", "test/test_pry_note.rb"]
+ s.homepage = "https://github.com/banister"
+ s.require_paths = ["lib"]
+ s.rubygems_version = "1.8.23"
+ s.summary = "Ease refactoring and exploration by attaching notes to methods and classes in Pry"
+ s.test_files = ["test/helper.rb", "test/test_pry_note.rb"]
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<rake>, ["~> 0.9"])
+ else
+ s.add_dependency(%q<rake>, ["~> 0.9"])
+ end
+ else
+ s.add_dependency(%q<rake>, ["~> 0.9"])
+ end
+end

0 comments on commit b8726e0

Please sign in to comment.