Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

updated Makefile.PL

  • Loading branch information...
commit 6636cad1848eee795ca79ed14741590880a63f03 1 parent 2012e04
@barbie authored
Showing with 55 additions and 44 deletions.
  1. +29 −27 Changes
  2. +3 −5 META.yml
  3. +23 −12 Makefile.PL
View
56 Changes
@@ -1,45 +1,47 @@
# Changes log for Data::Phrasebook::Loader::Ini
-0.11 current
+0.11 current
- spelling fix. (thanks to Florian Schlichting & Gregor Herrmann).
- removed License files from distro.
- - Artistic License v2 now sole license.
+ - Artistic License v2 now sole license.
- removed DSLIP info.
+ - added minimum perl version (5.006).
+ - reworked Makefile.PL for clarity.
0.10 01/03/2007
- - Fixed META.yml typos.
- - Added META.yml test script.
+ - Fixed META.yml typos.
+ - Added META.yml test script.
-0.09 22/02/2007
- - Handwritten META.yml to conform to current specs.
- - Changed all instances of LICENCE to LICENSE as *apparently*, to all
- non-British users of this module, this a bug! I beg to differ -
- http://dictionary.reference.com/search?q=licence
- - Added an examples directory. Nothing in it yet, except a request
- for interesting scripts.
+0.09 22/02/2007
+ - Handwritten META.yml to conform to current specs.
+ - Changed all instances of LICENCE to LICENSE as *apparently*, to all
+ non-British users of this module, this a bug! I beg to differ -
+ http://dictionary.reference.com/search?q=licence
+ - Added an examples directory. Nothing in it yet, except a request
+ for interesting scripts.
-0.08 09/08/2005
- - upped prerequisite for Data::Phrasebook to 0.23.
- - added keywords() support.
- - added POD for continuation lines.
+0.08 09/08/2005
+ - upped prerequisite for Data::Phrasebook to 0.23.
+ - added keywords() support.
+ - added POD for continuation lines.
-0.07 15/06/2005
- - upped prerequisite for Data::Phrasebook to 0.22.
+0.07 15/06/2005
+ - upped prerequisite for Data::Phrasebook to 0.22.
-0.06 13/06/2005
- - dictionary reload bug spotted (Sam Tregar).
- - added dicts() support.
+0.06 13/06/2005
+ - dictionary reload bug spotted (Sam Tregar).
+ - added dicts() support.
-0.05 25/03/2005
- - Added DSLIP information
- - Rewrote test scripts
- - Devel::Cover - 98.2%
+0.05 25/03/2005
+ - Added DSLIP information
+ - Rewrote test scripts
+ - Devel::Cover - 98.2%
-0.04 03/03/2005
- - POD updates.
+0.04 03/03/2005
+ - POD updates.
0.03 02 Mar 2005
- - Removed Test::MockObject from tests. No longer needed.
+ - Removed Test::MockObject from tests. No longer needed.
0.02 23 Feb 2005
- revamped and renamed as part of the Data::Phrasebook framework
View
8 META.yml
@@ -1,7 +1,7 @@
--- #YAML:1.0
name: Data-Phrasebook-Loader-Ini
version: 0.11
-abstract: This module provides a loader class for phrasebook implementations using INI files.
+abstract: Loader class for phrasebook implementations using INI files
author:
- Barbie <barbie@cpan.org>
@@ -10,16 +10,14 @@ distribution_type: module
installdirs: site
requires:
- Data::Phrasebook: 0.23
+ Data::Phrasebook: 0.24
Config::IniFiles: 0
- Test::More: 0.47
recommends:
- Test::More: 0.47
Test::Pod: 1.00
Test::Pod::Coverage: 0.08
Test::YAML::Meta: 0
build_requires:
- Test::More: 0.47
+ Test::More: 0.70
provides:
Data::Phrasebook::Loader::Ini:
View
35 Makefile.PL
@@ -1,15 +1,26 @@
+#!/usr/bin/perl
+
+use strict;
+use warnings;
+use 5.006;
+
use ExtUtils::MakeMaker;
+
WriteMakefile(
- NAME => 'Data::Phrasebook::Loader::Ini',
- VERSION_FROM => 'lib/Data/Phrasebook/Loader/Ini.pm',
- PREREQ_PM => {
- 'Data::Phrasebook' => '0.23',
- 'Config::IniFiles' => '0',
- 'Test::More' => '0.47',
- },
- NO_META => 1,
-
- ($] >= 5.005 ?
- (ABSTRACT_FROM => 'lib/Data/Phrasebook/Loader/Ini.pm',
- AUTHOR => 'Barbie <barbie@cpan.org>') : ()),
+ AUTHOR => 'Barbie <barbie@cpan.org>',
+ NAME => 'Data::Phrasebook::Loader::Ini',
+ VERSION_FROM => 'lib/Data/Phrasebook/Loader/Ini.pm',
+ ABSTRACT => 'Loader class for phrasebook implementations using INI files',
+ NO_META => 1,
+ PREREQ_PM => {
+
+ # runtime prereqs
+ 'Data::Phrasebook' => '0.24',
+ 'Config::IniFiles' => '0',
+
+ # build/test prereqs
+ 'Test::More' => '0.70',
+ 'IO::File' => '0'
+
+ }
);
Please sign in to comment.
Something went wrong with that request. Please try again.