Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

JSON v2 check added, and prepped for release

  • Loading branch information...
commit a9cb4d76ecb995faaa7c5b434463ab9802ec53b1 1 parent 0076080
@barbie authored
View
4 Changes
@@ -1,6 +1,10 @@
Revision history for Perl library Devel-Platform-Info
=====================================================
+0.06 15/07/2010
+ - better 32/64 detection for BSD (thanks to Chris Williams for help)
+ - upped version check of Test-JSON-Meta to ensure we have JSON v2.
+
0.05 12/07/2010
- updated Mac version check (Colin Newell).
- added Mac tests (Colin Newell).
View
18 META.json
@@ -1,6 +1,6 @@
{
"name": "Devel-Platform-Info",
- "version": "0.05",
+ "version": "0.06",
"abstract": "Unified framework for obtaining common platform metadata.",
"author": [
"Barbie (BARBIE) <barbie@cpan.org>",
@@ -56,35 +56,35 @@
"provides": {
"Devel::Platform::Info": {
"file": "lib/Devel/Platform/Info.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::BSD": {
"file": "lib/Devel/Platform/Info/BSD.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::Irix": {
"file": "lib/Devel/Platform/Info/Irix.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::Linux": {
"file": "lib/Devel/Platform/Info/Linux.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::Mac": {
"file": "lib/Devel/Platform/Info/Mac.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::SCO": {
"file": "lib/Devel/Platform/Info/SCO.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::Solaris": {
"file": "lib/Devel/Platform/Info/Solaris.pm",
- "version": "0.05"
+ "version": "0.06"
},
"Devel::Platform::Info::Win32": {
"file": "lib/Devel/Platform/Info/Win32.pm",
- "version": "0.05"
+ "version": "0.06"
}
},
"no_index": {
View
18 META.yml
@@ -1,6 +1,6 @@
--- #YAML:1.0
name: Devel-Platform-Info
-version: 0.05
+version: 0.06
abstract: Unified framework for obtaining common platform metadata
author:
- Barbie (BARBIE) <barbie@cpan.org>
@@ -27,28 +27,28 @@ build_requires:
provides:
Devel::Platform::Info:
file: lib/Devel/Platform/Info.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::BSD:
file: lib/Devel/Platform/Info/BSD.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::Irix:
file: lib/Devel/Platform/Info/Irix.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::Linux:
file: lib/Devel/Platform/Info/Linux.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::Mac:
file: lib/Devel/Platform/Info/Mac.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::SCO:
file: lib/Devel/Platform/Info/SCO.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::Solaris:
file: lib/Devel/Platform/Info/Solaris.pm
- version: 0.05
+ version: 0.06
Devel::Platform::Info::Win32:
file: lib/Devel/Platform/Info/Win32.pm
- version: 0.05
+ version: 0.06
no_index:
directory:
View
2  lib/Devel/Platform/Info.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/BSD.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/Irix.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/Linux.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/Mac.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#-------------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/SCO.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/Solaris.pm
@@ -4,7 +4,7 @@ use strict;
use warnings;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
2  lib/Devel/Platform/Info/Win32.pm
@@ -5,7 +5,7 @@ use warnings;
use POSIX;
use vars qw($VERSION);
-$VERSION = '0.05';
+$VERSION = '0.06';
#----------------------------------------------------------------------------
View
4 t/96metatest.t
@@ -4,8 +4,8 @@ use Test::More;
plan skip_all => "Author tests not required for installation"
unless ( $ENV{AUTOMATED_TESTING} );
-eval "use Test::JSON::Meta";
-plan skip_all => "Test::JSON::Meta required for testing META.json files" if $@;
+eval "use Test::JSON::Meta 0.08";
+plan skip_all => "Test::JSON::Meta 0.08 required for testing META.json files" if $@;
plan no_plan;
Please sign in to comment.
Something went wrong with that request. Please try again.