@dbarashev dbarashev released this Feb 21, 2017 · 570 commits to master since this release

Assets 6

Updated calendars, translations and a few bugfixes. The list of closed bugs is available on release milestone page

Installation notes and system requirements

GanttProject 2.8.2 requires Java Runtime version 7 or higher. We recommend using the latest Java Runtime from Oracle.

Windows

Provided that Java Runtime is installed, it is enough to run the installer executable and complete the wizard steps to install GanttProject.

Upgrading from previous versions
Assorted effects, such as duplicated exports or broken Properties dialog, may be observed if GanttProject 2.8.2 is installed on top of GanttProject 2.8.1 into the same folder.

Install GanttProject 2.8.2 into a clean (or new) folder. However, if you have already installed it on top of 2.8.1, you can just remove folder plugins/net.sourceforge.ganttproject from the installation folder to fix the issue.

Viruses in the installer
Some anti-virus programs may report viruses in the installer. This is a known issue which happens to installers very often. It doesn't mean that the file is infected, it rather means that antivirus engine have seen malware packed using similar installer. File ganttproject-2.8.2-r2069.exe was checked with VirusTotal online service and only 2 out of 57 antivirus engines reported positive results. Provided that the file which you downloaded is the original one, we're certain that positive results are false positive. You can check if you downloaded the original file by checking its MD5 checksum. The original checksum of ganttproject-2.8.2-r2069.exe is 6c512df96e5ad09c34540fc7a27761d8 (case insensitive).

If you can't or don't want to run program which your antivirus engine considers as infected, we recommend using ZIP distribution. It involves no native code (except for Java machine) and doesn't require Administrator priveleges.

Mac OSX

Provided that Java Runtime is installed, it is enough to drag GanttProject application into Applications.

Ubuntu/Mint/ other Debian-based Linux distros

Install deb package using your system software/package management tools.