New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

node-gyp builds to Release/scrypt.node #169

Closed
ryanio opened this Issue Jan 11, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@ryanio

ryanio commented Jan 11, 2018

Hey, thanks for the great library.

I'm running it on Mac OS X 10.13.2 with node v9.2.1 and I'm getting the error:

 Cannot find module './build/Release/scrypt' from 'index.js'

It looks like node-gyp is building to Release/scrypt.node:

...
SOLINK_MODULE(target) Release/scrypt.node
gyp info ok

But index.js looks for: require("./build/Release/scrypt")

Related to #162, but if I just rename to require("./build/Release/scrypt.node") I get the error:

Module parse failed: node_modules/scrypt/build/Release/scrypt.node Unexpected character '�' (1:0)
[1] You may need an appropriate loader to handle this file type.

Would love any tips or clues into what to try next.

@ryanio

This comment has been minimized.

Show comment
Hide comment
@ryanio

ryanio Jan 11, 2018

I believe using node-loader along with @fanatid's PR #144 fixed this for me :)

ryanio commented Jan 11, 2018

I believe using node-loader along with @fanatid's PR #144 fixed this for me :)

@ryanio ryanio closed this Jan 11, 2018

@joey-he8x

This comment has been minimized.

Show comment
Hide comment
@joey-he8x

joey-he8x Jan 30, 2018

Why close the issue while the problem is still not fixed, I want to use it in node env, node-loader not helping. @ryanio

joey-he8x commented Jan 30, 2018

Why close the issue while the problem is still not fixed, I want to use it in node env, node-loader not helping. @ryanio

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment