Pow won't run a fresh rails 3 app #178

Closed
adrusi opened this Issue Jul 8, 2011 · 3 comments

Projects

None yet

4 participants

adrusi commented Jul 8, 2011

I just reinstalled rails, created a new project, didn't change a single character, symlinked it into ~/.pow, opened http://writtr.dev/("writtr" being the name of the project) and it didn't work. Running $ rails server worked

benatkin commented Jul 9, 2011

Did you try again after running rails server? Did you do a bundle install? Did you try setting up rvm to make sure you get the same ruby environment in pow and in the terminal?

I just tried re-installing pow and creating a rails 3 app with a new gemset. Here's what I ran after re-installing pow:

cd ~/src/util
rvm gemset use rails3_fresh --create
gem install rails
rails new hello
cd hello
bundle install
echo rvm $(rvm current) > .rvmrc
ln -s ~/src/util/hello ~/.pow/hello

I then went to http://hello.dev/ and got the rails welcome page.

adrusi commented Jul 10, 2011

I did all of those except bundle install, but I can't test it easily
anymore because I decided to build the app in sinatra instead.

On Sat, Jul 9, 2011 at 2:17 AM, benatkin <
reply@reply.github.com>wrote:

Did you try again after running rails server? Did you do a bundle install? Did you try setting up rvm to make sure you get the same ruby
environment in pow and in the terminal?

Reply to this email directly or view it on GitHub:
#178 (comment)

@josh josh closed this Jul 11, 2011
jdurand commented Dec 28, 2012

I also had an issue running a rails app with Pow.
This solved it for me :
echo rvm $(rvm current) > .rvmrc

Pow's doc says to put this in your .rvmc file :
rvm 1.8.7

So in put rvm 1.9.3 ... makes sense right?... no!

Pow launches my rails 3.2 app successfully with this in my .rvmc :
rvm ruby-1.9.3-p327

Since this caused me a headache I figured I'd share.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment