Skip to content
Browse files

Fix Rails 3.1 generator breakage and update to latest RSpec.

  • Loading branch information...
1 parent ec0d916 commit c4a2454bb549e2457dea24c02906e5a9ffed864e @seancribbs seancribbs committed Jan 12, 2012
Showing with 9 additions and 4 deletions.
  1. +1 −1 .gitignore
  2. +1 −0 .rspec
  3. +1 −0 lib/rails/generators/ripple_generator.rb
  4. +2 −2 ripple.gemspec
  5. +4 −1 spec/support/generator_setup.rb
View
2 .gitignore
@@ -24,7 +24,7 @@ doc
.yardoc
.bundle
spec/support/test_server.yml
-Gemfile.lock
+Gemfile*.lock
**/bin
*.rbc
.rvmrc
View
1 .rspec
@@ -0,0 +1 @@
+--color
View
1 lib/rails/generators/ripple_generator.rb
@@ -1,3 +1,4 @@
+require 'rails/generators'
require "rails/generators/named_base"
require "rails/generators/active_model"
View
4 ripple.gemspec
@@ -12,8 +12,8 @@ Gem::Specification.new do |gem|
gem.authors = ["Sean Cribbs"]
# Deps
- gem.add_development_dependency "rspec", "~>2.6.0"
- gem.add_development_dependency 'rake', '~> 0.8.7'
+ gem.add_development_dependency "rspec", "~>2.8.0"
+ gem.add_development_dependency 'rake'
gem.add_development_dependency 'ammeter', '~>0.2.2'
gem.add_dependency "riak-client", "~>#{Ripple::VERSION}"
gem.add_dependency "activesupport", [">= 3.0.0", "< 3.2.0"]
View
5 spec/support/generator_setup.rb
@@ -1,7 +1,10 @@
+require 'ammeter/init'
+require 'fileutils'
+
module GeneratorSetup
+ include FileUtils
def self.included(group)
group.destination File.expand_path(File.join('..','..','..','tmp'), __FILE__)
- group.send :include, FileUtils
group.before(:each){ Dir.chdir destination_root }
end
end

0 comments on commit c4a2454

Please sign in to comment.
Something went wrong with that request. Please try again.