Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Fix unit tests.

  • Loading branch information...
commit 1c83ed91b1e23be146cf215a6150f2e6ab60d686 1 parent 981759a
@seancribbs seancribbs authored
Showing with 2 additions and 0 deletions.
  1. +1 −0  .travis.yml
  2. +1 −0  unit_tests.php
View
1  .travis.yml
@@ -1,4 +1,5 @@
language: php
+before_script: sudo search-cmd install searchbucket
script: make test
notifications:
webhooks: http://basho-engbot.herokuapp.com/travis?key=8d594c660ec46f616e37e24fd941c0ea1fc67963
View
1  unit_tests.php
@@ -8,6 +8,7 @@
define('PORT', 8098);
define('VERBOSE', true);
+date_default_timezone_set("UTC");
print("Starting Unit Tests\n---\n");

4 comments on commit 1c83ed9

@MarcoDeBortoli

Wouldn't be better to add the search hook programmatically within the test suite setting up the related properties for the bucket rather than do it with the before_script?

@seancribbs

@MarcoDeBortoli Yes, if the functionality within the client works. We know that search-cmd works, it's not under test.

@MarcoDeBortoli

The client doesn't have that feature in the meaning that you cannot setup the hook while creating the bucket at first.
But I tried myself to set the relative properties afterwords and it worked. I'll create a quick fix for it and open a PR.
Actually I think I should open some.

@wojons

When i sent a pull request the test failed because of the line

sudo search-cmd install searchbucket

travis returned

$ sudo search-cmd install searchbucket
21Attempting to restart script through sudo -H -u riak
22/etc/profile.d/phpenv.sh: line 4: phpenv: command not found
23Node is not running!
24
25
26before_script: 'sudo search-cmd install searchbucket' returned false.

Please sign in to comment.
Something went wrong with that request. Please try again.