riak 1.2 is not starting on mac os x lion #185

Closed
sendtopms opened this Issue Jul 17, 2012 · 1 comment

Comments

Projects
None yet
2 participants

I compiled both from source as well as from the zipped version by basho.

Erlang R15B (erts-5.9) [source] [smp:4:4] [async-threads:64] [hipe] [kernel-poll:true]

21:00:14.839 [info] Application lager started on node 'riak@127.0.0.1'
21:00:14.875 [error] CRASH REPORT Process <0.59.0> with 0 neighbours exited with reason: no such process or port in call to gen_server:call(riak_core_stat_cache, {register,riak_api,{riak_api_stat,produce_stats,[]},5}) in application_master:init/4 line 138
{"Kernel pid terminated",application_controller,"{application_start_failure,riak_api,{bad_return,{{riak_api_app,start,[normal,[]]},{'EXIT',{noproc,{gen_server,call,[riak_core_stat_cache,{register,riak_api,{riak_api_stat,produce_stats,[]},5}]}}}}}}"}

Crash dump was written to: ./log/erl_crash.dump
Kernel pid terminated (application_controller) ({application_start_failure,riak_api,{bad_return,{{riak_api_app,start,[normal,[]]},{'EXIT',{noproc,{gen_server,call,[riak_core_stat_cache,{register,ria

Contributor

seancribbs commented Jul 17, 2012

This is already being addressed by basho/riak_api#6

seancribbs closed this Jul 17, 2012

@hmmr hmmr pushed a commit that referenced this issue Nov 8, 2016

Jared Morrow Merge pull request #185 from basho/jhc-reip
reip should check that node is not running
80db613
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment