Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Remove legacy listkeys config option #239

Merged
merged 1 commit into from

2 participants

@kellymclaughlin
Collaborator

Legacy keylisting is being removed from riak_kv so the legacy_keylisting configuration option is now obsolete.

@kellymclaughlin kellymclaughlin Remove legacy_keylisting config option from app.config template
Fixes: RIAK239

Legacy keylisting is being removed from riak_kv so the
legacy_keylisting configuration option is now obsolete.
a53237f
@kellymclaughlin
Collaborator

Related riak_kv pr is here.

@slfritchie slfritchie was assigned
@slfritchie
Owner

Hrm, I thought that I saw this same app config change with the Luke app removal review that I did recently? If I'm thinking of another config item that @beerriot removed, then great.

This same packaging change should also be applied to the riak_ee repo?

I don't see anything in basho/riak_kv#436 that looks objectionable, +1 to merge.

@kellymclaughlin
Collaborator

I think it was a similar, but different item that was in the luke removal. I've added a pr here to mirror this change in riak_ee.

@kellymclaughlin kellymclaughlin merged commit a53237f into master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 14, 2012
  1. @kellymclaughlin

    Remove legacy_keylisting config option from app.config template

    kellymclaughlin authored
    Fixes: RIAK239
    
    Legacy keylisting is being removed from riak_kv so the
    legacy_keylisting configuration option is now obsolete.
This page is out of date. Refresh to see the latest.
Showing with 0 additions and 7 deletions.
  1. +0 −7 rel/files/app.config
View
7 rel/files/app.config
@@ -148,13 +148,6 @@
%% Only set true if *all* nodes in the cluster are upgraded to 1.0
{vnode_vclocks, true},
- %% This option enables compatability of bucket and key listing
- %% with 0.14 and earlier versions. Once a rolling upgrade to
- %% a version > 0.14 is completed for a cluster, this should be
- %% set to false for improved performance for bucket and key
- %% listing operations.
- {legacy_keylisting, false},
-
%% This option toggles compatibility of keylisting with 1.0
%% and earlier versions. Once a rolling upgrade to a version
%% > 1.0 is completed for a cluster, this should be set to
Something went wrong with that request. Please try again.