Support Cabal 1.8 #13

Closed
singpolyma opened this Issue Mar 23, 2013 · 1 comment

Projects

None yet

2 participants

@singpolyma

I am trying to deploy an app on Debian stable. This library seems to build just fine under Cabal 1.8 if I manually edit the .cabal file to allow it. Why is this version disallowed in the source right now?

@basvandijk
Owner

Why is this version disallowed in the source right now?

IIRC this was to support the benchmark section in the cabal file.

However, I would accept a pull request if you say it also configures and builds with Cabal-1.8.

@basvandijk basvandijk pushed a commit that closed this issue Mar 29, 2013
@singpolyma Stephen Paul Weber + singpolyma Support Cabal 1.8
Gives warnings about the benchmark and test-suite sections, but these
do not prevent it from configuring and building correctly.

Closes #13
5be531d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment