Permalink
Browse files

Add error when CS is out of date to resolve confusion

  • Loading branch information...
1 parent 99318ba commit f84278ac395f13e94e660c71a1a4d81a655db597 @airhorns airhorns committed Apr 10, 2012
Showing with 4 additions and 0 deletions.
  1. +4 −0 Cakefile
View
@@ -28,6 +28,10 @@ pipedExec = do ->
running = false
callback(code)
+unless require('coffee-script').VERSION == '1.3.0'
+ console.error "Please `npm update`, your packages are out of date."
+ process.exit 1
+
task 'build', 'compile Batman.js and all the tools', (options) ->
files = glob.sync('./src/**/*').concat(glob.sync('./tests/lib/*'))
muffin.run

0 comments on commit f84278a

Please sign in to comment.