Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bumped the (strict) upper bound on the QuickCheck dependency from 2.6 to 2.7 #55

Merged
merged 1 commit into from

3 participants

@gcross

This patch bumps the (exclusive) upper version bound on QuickCheck from 2.6 to 2.7. Please accept this patch because at this time test-framework-quickcheck2 is not reliably cabal-installable as it requires that an older version of QuickCheck be installed than that in that latest Haskell Platform.

@bos
bos commented

Applied to haskell/test-framework since Max has disappeared.

@batterseapower batterseapower merged commit 44fa12a into batterseapower:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Aug 12, 2013
  1. @gcross
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  quickcheck2/test-framework-quickcheck2.cabal
View
2  quickcheck2/test-framework-quickcheck2.cabal
@@ -22,7 +22,7 @@ Flag Base3
Library
Exposed-Modules: Test.Framework.Providers.QuickCheck2
- Build-Depends: test-framework >= 0.7.1, QuickCheck >= 2.4 && < 2.6, extensible-exceptions >= 0.1.1 && < 0.2.0
+ Build-Depends: test-framework >= 0.7.1, QuickCheck >= 2.4 && < 2.7, extensible-exceptions >= 0.1.1 && < 0.2.0
if flag(base3)
Build-Depends: base >= 3 && < 4, random >= 1
else
Something went wrong with that request. Please try again.