New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error messages when changing repository_rule arguments #3143

Open
abergmeier-dsfishlabs opened this Issue Jun 8, 2017 · 1 comment

Comments

@abergmeier-dsfishlabs
Copy link
Contributor

abergmeier-dsfishlabs commented Jun 8, 2017

Description of the problem / feature request / question:

In WORKSPACE, I changed:

my_repo(
    name = "foo",
    build_files_path = __workspace_dir__ + "/third_party/abyss",

to

my_repo(
    name = "foo",
    build_files_path = select({
        "//conditions:default": __workspace_dir__ + "/third_party/abyss",
    }),

As a result, I then get the error:

no such package '@foo//' <...> (Directory not empty) and referenced by <...>

Changing it back, it still remains broken.

Environment info

  • Operating System: Windows 10
  • Bazel version (output of bazel info release): 0.5.1

Have you found anything relevant by searching the web?

Nope

@abergmeier-dsfishlabs

This comment has been minimized.

Copy link
Contributor

abergmeier-dsfishlabs commented Jun 8, 2017

BTW: I am pretty sure that repository invalidation does not currently work with 0.5.1 on Windows.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment