New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

incompatible_disable_expand_if_all_available_in_flag_set: Only use expand_if_all_available in flag_group in CROSSTOOL #7008

Closed
hlopko opened this Issue Dec 28, 2018 · 0 comments

Comments

Projects
None yet
3 participants
@hlopko
Copy link
Contributor

hlopko commented Dec 28, 2018

Flag: --incompatible_disable_expand_if_all_available_in_flag_set
Available since: 0.22 (January 2019 release)
Will be flipped in: 0.24 (February 2019 release)
Tracking issue: #5883
Rollout doc: docs.google.com/document/d/1uv4c1zag6KvdI31qdx8C6jiTognXPQrxgsUpVefm9fM/edit#

Motivation

This is a part of larger incompatible change #6861. This is a small and innocent cleanup, but since we have a migration tool for #6861, this will be an effortless change for users already migrating for #6861. This flag will only be flipped when #6861 is flipped.

Migration

Use the legacy_fields_migrator from #6861.

@hlopko hlopko self-assigned this Dec 28, 2018

bazel-io pushed a commit that referenced this issue Jan 2, 2019

Add --incompatible_disable_expand_if_all_available_in_flag_set
Corresponding issue: #7008

RELNOTES: None.
PiperOrigin-RevId: 227522028

@meteorcloudy meteorcloudy changed the title --incompatible_disable_expand_if_all_available_in_flag_set: Only use expand_if_all_available in flag_group in CROSSTOOL incompatible_disable_expand_if_all_available_in_flag_set: Only use expand_if_all_available in flag_group in CROSSTOOL Jan 3, 2019

bazel-io pushed a commit to bazelbuild/rules_cc that referenced this issue Jan 11, 2019

Add --incompatible_disable_expand_if_all_available_in_flag_set
Corresponding issue: bazelbuild/bazel#7008

RELNOTES: None.
PiperOrigin-RevId: 227522028

bazel-io pushed a commit to bazelbuild/rules_cc that referenced this issue Feb 18, 2019

Flip --incompatible_disable_expand_if_all_available_in_flag_set
FlagSets in the CROSSTOOL no longer accept expand_if_all_available field

Fixes #7008

RELNOTES: `--incompatible_disable_expand_if_all_available_in_flag_set` has been flipped (bazelbuild/bazel#7008)
PiperOrigin-RevId: 234466411

@bazel-io bazel-io closed this in 4eea5c6 Feb 18, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment