Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Is there a way to run prelude without any ido mode? #447

Closed
rgrinberg opened this Issue · 4 comments

3 participants

@rgrinberg

My goal is to try out icicles which is incompatible with ido. Is there a setting to turn off all ido?

@bbatsov
Owner

You can always simply disable ido in your personal config. I guess I should move it into a separate module to make it easier for users like you to disable it.

@rgrinberg

Would be much appreciated. Thanks for making prelude!

@bbatsov bbatsov closed this issue from a commit
@bbatsov [Fix #447] Extract ido config into a module
This should make it simpler to disable ido completely if you want to use
an alternative library (like `icomplete` or `icicles` for instance).
3cdb7f3
@bbatsov bbatsov closed this in 3cdb7f3
@bbatsov
Owner

Done. ido now lives in a module that you can disable. Maybe one day we'll have an icicles modules as well, if someone submits one.

@jjcomer

I just submitted PR #452 to fix a little typo in the ido module

@WaYdotNET WaYdotNET referenced this issue from a commit
@WaYdotNET WaYdotNET Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Fix typo in prelude-ido
  [Fix #451] Add the ability to preload personal code
  [Fix #447] Extract ido config into a module
  New keychord xx -> execute-extended-command
  [Fix #444] Add command prelude-update-packages
1b1118b
@bixuanzju bixuanzju referenced this issue from a commit
@bixuanzju bixuanzju Merge branch 'master' of https://github.com/bbatsov/prelude
* 'master' of https://github.com/bbatsov/prelude:
  Fix epl-upgrade invocation
  Add prefix arg support prelude-update-packages
  Fix typo in prelude-ido
  [Fix #451] Add the ability to preload personal code
  [Fix #447] Extract ido config into a module
  New keychord xx -> execute-extended-command
  [Fix #444] Add command prelude-update-packages
fb8f5fe
@jduhamel jduhamel referenced this issue from a commit in jduhamel/prelude
@jduhamel jduhamel Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Improve tab's behavior
  Add wrapping commands to ielm-map
  Simplify sexp wrapping code
  [Fix #433] Disable problematic binding M-[
  Fix epl-upgrade invocation
  Add prefix arg support prelude-update-packages
  Fix typo in prelude-ido
  [Fix #451] Add the ability to preload personal code
  [Fix #447] Extract ido config into a module
  New keychord xx -> execute-extended-command
  [Fix #444] Add command prelude-update-packages
  Use prelude-require-packages everywhere
b441b57
@driftcrow driftcrow referenced this issue from a commit in driftcrow/prelude
@driftcrow driftcrow Merge remote-tracking branch 'refs/remotes/bbatsov/master'
* refs/remotes/bbatsov/master:
  Improve tab's behavior
  Add wrapping commands to ielm-map
  Simplify sexp wrapping code
  [Fix #433] Disable problematic binding M-[
  Fix epl-upgrade invocation
  Add prefix arg support prelude-update-packages
  Fix typo in prelude-ido
  [Fix #451] Add the ability to preload personal code
  [Fix #447] Extract ido config into a module
  New keychord xx -> execute-extended-command
  [Fix #444] Add command prelude-update-packages
2cc3b2e
@sorenmacbeth sorenmacbeth referenced this issue from a commit
@bbatsov [Fix #447] Extract ido config into a module
This should make it simpler to disable ido completely if you want to use
an alternative library (like `icomplete` or `icicles` for instance).
feebb08
@driftcrow driftcrow referenced this issue from a commit in driftcrow/prelude
@driftcrow driftcrow Merge branch 'master' of github.com:driftcrow/prelude
* 'master' of github.com:driftcrow/prelude:
  fix multi-cursor .mc-lists
  Improve tab's behavior
  Add wrapping commands to ielm-map
  Simplify sexp wrapping code
  [Fix #433] Disable problematic binding M-[
  Fix epl-upgrade invocation
  Add prefix arg support prelude-update-packages
  Fix typo in prelude-ido
  [Fix #451] Add the ability to preload personal code
  [Fix #447] Extract ido config into a module
  New keychord xx -> execute-extended-command
  [Fix #444] Add command prelude-update-packages
  remove paredit config
4026624
@kelleyk kelleyk referenced this issue from a commit in kelleyk/emacs-prelude
@bbatsov [Fix #447] Extract ido config into a module
This should make it simpler to disable ido completely if you want to use
an alternative library (like `icomplete` or `icicles` for instance).
4d4b440
@paddymul paddymul referenced this issue from a commit in paddymul/prelude
@bbatsov [Fix #447] Extract ido config into a module
This should make it simpler to disable ido completely if you want to use
an alternative library (like `icomplete` or `icicles` for instance).
ff67e98
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.