New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

New install, gets error: file-error "Cannot open load file" "package" #85

Closed
albertsj1 opened this Issue Feb 26, 2012 · 2 comments

Comments

Projects
None yet
2 participants
@albertsj1

albertsj1 commented Feb 26, 2012

Hi. I just followed the instructions to install emacs24 via homebrew and prelude and got the following error when running 'emacs --debug-init'

Debugger entered--Lisp error: (file-error "Cannot open load file" "package")
  require(package)
  eval-buffer(#<buffer  *load*<2>> nil "/Users/jalberts/.emacs.d/modules/prelude-packages.el" nil t)  ; Reading at buffer position 1205
  load-with-code-conversion("/Users/jalberts/.emacs.d/modules/prelude-packages.el" "/Users/jalberts/.emacs.d/modules/prelude-packages.el" nil t)
  require(prelude-packages)
  eval-buffer(#<buffer  *load*> nil "/Users/jalberts/.emacs.d/init.el" nil t)  ; Reading at buffer position 2421
  load-with-code-conversion("/Users/jalberts/.emacs.d/init.el" "/Users/jalberts/.emacs.d/init.el" t t)
  load("/Users/jalberts/.emacs.d/init" t t)
  #[nil "^H\205\264^@   \306=\203^Q^@\307^H\310Q\2027^@ \311=\2033^@\312\307\313\314#\203#^@\315\2027^@\312\307\313\316#\203/^@\317\2027^@\315\2027^@\307^H\320Q^Z\321^S\322\n\321\211#\210^K\321=\203_^@\323\324\325\307^H\326Q!\"^\\322\f\3$
  command-line()
  normal-top-level()

I installed emacs and prelude doing the following:

$ brew install emacs --cocoa --use-git-head --HEAD
$ cp -r /usr/local/Cellar/emacs/HEAD/Emacs.app /Applications/
$ sudo rm /usr/bin/emacs
$ sudo rm -rf /usr/share/emacs
$ curl -L https://github.com/bbatsov/emacs-prelude/raw/master/utils/installer.sh | sh

Any ideas?

Thanks
John

@bbatsov

This comment has been minimized.

Owner

bbatsov commented Feb 26, 2012

Maybe a bad git checkout (package.el is a core package so I cannot image what might cause it to go missing)? Can you try using a prebuilt Emacs for OSX instead? The latest pretest should do fine.

@albertsj1

This comment has been minimized.

albertsj1 commented Feb 26, 2012

Thanks for quick response. You were right. It must not have built properly.

I did the following and everything seems to be working great.

$ brew remove --force emacs
$ brew brew install emacs --cocoa --use-git-head --HEAD
$ brew linkapps

Thanks again.
John

@albertsj1 albertsj1 closed this Feb 26, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment