Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

rails3 #15

Open
markmcdonald51 opened this Issue · 1 comment

2 participants

@markmcdonald51

Hi Benoit,

Wondering if you have this working with Rails3 yet.

I just tried to add it into a rails3.01 project and got this when I do 'rails g' (looking for the papermill generator)

k@mark-solo:~/rails_apps/rails3/hoven$ rails g
DEPRECATION WARNING: RAILS_ROOT is deprecated. Please use ::Rails.root.to_s. (called from at /home/mark/rails_apps/rails3/hoven/config/application.rb:7)
/home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activerecord-3.0.1/lib/active_record/base.rb:1016:in method_missing': undefined methodbefore_post_process' for #Class:0x000000035381f0 (NoMethodError)
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/papermill-2.1.1/lib/papermill/papermill_asset.rb:9:in <class:PapermillAsset>'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/papermill-2.1.1/lib/papermill/papermill_asset.rb:1:in
'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:239:in require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:239:in
block in require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:225:in block in load_dependency'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:591:in
new_constants_in'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:225:in load_dependency'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/activesupport-3.0.1/lib/active_support/dependencies.rb:239:in
require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/papermill-2.1.1/lib/papermill.rb:26:in <top (required)>'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:64:in
require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:64:in block (2 levels) in require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:62:in
each'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:62:in block in require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:51:in
each'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler/runtime.rb:51:in require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/bundler-1.0.3/lib/bundler.rb:112:in
require'
from /home/mark/rails_apps/rails3/hoven/config/application.rb:7:in <top (required)>'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/railties-3.0.1/lib/rails/commands.rb:15:in
require'
from /home/mark/.rvm/gems/ruby-1.9.2-p0/gems/railties-3.0.1/lib/rails/commands.rb:15:in <top (required)>'
from script/rails:6:in
require'
from script/rails:6:in `

'

Hope all is well.
Mark

@kodemunki

I asked this a little bit ago:
https://github.com/bbenezech/papermill/issues/closed#issue/14

I think this is a shame, as Papermill is such an elegant solution, and one of the reasons I have chosen to keep my projects at 2.3.8 for the moment.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.