Skip to content
Newer
Older
100644 35 lines (29 sloc) 1.48 KB
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
1 # -*- encoding: utf-8 -*-
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
2 $:.push File.expand_path('../lib', __FILE__)
3 require 'webmock/version'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
4
5 Gem::Specification.new do |s|
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
6 s.name = 'webmock'
7 s.version = WebMock::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ['Bartosz Blimke']
10 s.email = ['bartosz.blimke@gmail.com']
11 s.homepage = 'http://github.com/bblimke/webmock'
12 s.summary = %q{Library for stubbing HTTP requests in Ruby.}
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
13 s.description = %q{WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.}
14
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
15 s.rubyforge_project = 'webmock'
16
17 s.add_dependency 'addressable', '~> 2.2', '> 2.2.5'
18 s.add_dependency 'crack', '>=0.1.7'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
19
666a77d @jcf Remove RUBY_PLATFORM conditional from gemspec
jcf authored May 18, 2011
20 s.add_development_dependency 'rspec', '>= 2.0.0'
0c17403 @bblimke Upgraded dev dependencies: Typhoeus to 0.3.0 and HTTPClient to 2.2.4
authored Jan 22, 2012
21 s.add_development_dependency 'httpclient', '>= 2.2.4'
a56577e @bblimke Upgraded dev dependencies to lastest Patron 0.4.17 and updated patron…
authored Jan 22, 2012
22 s.add_development_dependency 'patron', '>= 0.4.17'
1d4899a @bblimke Changed default em-http-request version dependency to >= 1.0.0. Specs…
authored Jan 22, 2012
23 s.add_development_dependency 'em-http-request', '>= 1.0.0'
24 s.add_development_dependency 'em-synchrony', '>= 1.0.0' if RUBY_VERSION >= "1.9"
02a9c1d @bblimke Fixed compatibility with Curb >= 0.7.16 This breaks compatibility wit…
authored Jan 22, 2012
25 s.add_development_dependency 'curb', '>= 0.8.0'
0c17403 @bblimke Upgraded dev dependencies: Typhoeus to 0.3.0 and HTTPClient to 2.2.4
authored Jan 22, 2012
26 s.add_development_dependency 'typhoeus', '>= 0.3.0'
c6ef444 @bblimke Changed dev dependency to minitest >= 2.2.2
authored Jul 30, 2011
27 s.add_development_dependency 'minitest', '>= 2.2.2'
c70ab00 @bblimke Changed dev dependency on rdoc <=3.5 for ruby 1.8.6. rdoc >3.5 requir…
authored Aug 9, 2011
28 s.add_development_dependency 'rdoc', ((RUBY_VERSION == '1.8.6') ? '<= 3.5.0' : '>3.5.0')
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
29
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
30 s.files = `git ls-files`.split("\n")
31 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
32 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
33 s.require_paths = ['lib']
34 end
Something went wrong with that request. Please try again.