Skip to content
Newer
Older
100644 36 lines (30 sloc) 1.62 KB
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
1 # -*- encoding: utf-8 -*-
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
2 $:.push File.expand_path('../lib', __FILE__)
3 require 'webmock/version'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
4
5 Gem::Specification.new do |s|
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
6 s.name = 'webmock'
7 s.version = WebMock::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ['Bartosz Blimke']
10 s.email = ['bartosz.blimke@gmail.com']
11 s.homepage = 'http://github.com/bblimke/webmock'
12 s.summary = %q{Library for stubbing HTTP requests in Ruby.}
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
13 s.description = %q{WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.}
14
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
15 s.rubyforge_project = 'webmock'
16
e56d313 @bblimke Updated dependency on Addressable to version >= 2.2.7 to handle neste…
authored Feb 19, 2012
17 s.add_dependency 'addressable', '>= 2.2.7'
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
18 s.add_dependency 'crack', '>=0.1.7'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
19
7bc4f70 @bblimke webmock/rspec checks whether rspec/expectations is already loaded by …
authored May 12, 2012
20 s.add_development_dependency 'rspec', '~> 2.10'
0c17403 @bblimke Upgraded dev dependencies: Typhoeus to 0.3.0 and HTTPClient to 2.2.4
authored Jan 22, 2012
21 s.add_development_dependency 'httpclient', '>= 2.2.4'
8f6f989 @bblimke Updated http client libs to the latest version as dev dependencies
authored Mar 16, 2012
22 s.add_development_dependency 'patron', '>= 0.4.18' unless RUBY_PLATFORM =~ /java/
23 s.add_development_dependency 'em-http-request', '>= 1.0.2'
1d4899a @bblimke Changed default em-http-request version dependency to >= 1.0.0. Specs…
authored Jan 22, 2012
24 s.add_development_dependency 'em-synchrony', '>= 1.0.0' if RUBY_VERSION >= "1.9"
110ca90 @bblimke Curb is not supported on JRuby
authored Feb 19, 2012
25 s.add_development_dependency 'curb', '>= 0.8.0' unless RUBY_PLATFORM =~ /java/
8f6f989 @bblimke Updated http client libs to the latest version as dev dependencies
authored Mar 16, 2012
26 s.add_development_dependency 'typhoeus', '>= 0.3.3' unless RUBY_PLATFORM =~ /java/
27 s.add_development_dependency 'excon', '>= 0.11.0'
c6ef444 @bblimke Changed dev dependency to minitest >= 2.2.2
authored Jul 30, 2011
28 s.add_development_dependency 'minitest', '>= 2.2.2'
c70ab00 @bblimke Changed dev dependency on rdoc <=3.5 for ruby 1.8.6. rdoc >3.5 requir…
authored Aug 9, 2011
29 s.add_development_dependency 'rdoc', ((RUBY_VERSION == '1.8.6') ? '<= 3.5.0' : '>3.5.0')
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored Nov 20, 2009
30
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored May 18, 2011
31 s.files = `git ls-files`.split("\n")
32 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
33 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
34 s.require_paths = ['lib']
35 end
Something went wrong with that request. Please try again.