Skip to content
Newer
Older
100644 31 lines (25 sloc) 1.18 KB
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored
1 # -*- encoding: utf-8 -*-
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored
2 $:.push File.expand_path('../lib', __FILE__)
3 require 'webmock/version'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored
4
5 Gem::Specification.new do |s|
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored
6 s.name = 'webmock'
7 s.version = WebMock::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ['Bartosz Blimke']
10 s.email = ['bartosz.blimke@gmail.com']
11 s.homepage = 'http://github.com/bblimke/webmock'
12 s.summary = %q{Library for stubbing HTTP requests in Ruby.}
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored
13 s.description = %q{WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.}
14
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored
15 s.rubyforge_project = 'webmock'
16
17 s.add_dependency 'addressable', '~> 2.2', '> 2.2.5'
18 s.add_dependency 'crack', '>=0.1.7'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored
19
666a77d @jcf Remove RUBY_PLATFORM conditional from gemspec
jcf authored
20 s.add_development_dependency 'rspec', '>= 2.0.0'
21 s.add_development_dependency 'httpclient', '>= 2.1.5.2'
22 s.add_development_dependency 'patron', '>= 0.4.9'
23 s.add_development_dependency 'em-http-request', '>= 0.2.14'
24 s.add_development_dependency 'curb', '>= 0.7.8'
ec7ec68 Added gemspec for version 0.7.0
Bartosz Blimke authored
25
d73224f @jcf Rip out jeweler and use bundler instead
jcf authored
26 s.files = `git ls-files`.split("\n")
27 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
28 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
29 s.require_paths = ['lib']
30 end
Something went wrong with that request. Please try again.