Skip to content
This repository
Newer
Older
100644 38 lines (32 sloc) 1.788 kb
ec7ec68a »
2009-11-20 Added gemspec for version 0.7.0
1 # -*- encoding: utf-8 -*-
d73224f9 »
2011-05-18 Rip out jeweler and use bundler instead
2 $:.push File.expand_path('../lib', __FILE__)
3 require 'webmock/version'
ec7ec68a »
2009-11-20 Added gemspec for version 0.7.0
4
5 Gem::Specification.new do |s|
d73224f9 »
2011-05-18 Rip out jeweler and use bundler instead
6 s.name = 'webmock'
7 s.version = WebMock::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = ['Bartosz Blimke']
10 s.email = ['bartosz.blimke@gmail.com']
11 s.homepage = 'http://github.com/bblimke/webmock'
12 s.summary = %q{Library for stubbing HTTP requests in Ruby.}
ec7ec68a »
2009-11-20 Added gemspec for version 0.7.0
13 s.description = %q{WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.}
14
d73224f9 »
2011-05-18 Rip out jeweler and use bundler instead
15 s.rubyforge_project = 'webmock'
16
a893df91 »
2012-08-09 Setup Appraisal
17 s.add_dependency 'addressable', '>= 2.2', '< 2.4'
d73224f9 »
2011-05-18 Rip out jeweler and use bundler instead
18 s.add_dependency 'crack', '>=0.1.7'
ec7ec68a »
2009-11-20 Added gemspec for version 0.7.0
19
7bc4f70e »
2012-05-12 webmock/rspec checks whether rspec/expectations is already loaded by …
20 s.add_development_dependency 'rspec', '~> 2.10'
a893df91 »
2012-08-09 Setup Appraisal
21 s.add_development_dependency 'appraisal', '~> 0.4'
22 s.add_development_dependency 'rack', '~> 1.4'
0c17403f »
2012-01-22 Upgraded dev dependencies: Typhoeus to 0.3.0 and HTTPClient to 2.2.4
23 s.add_development_dependency 'httpclient', '>= 2.2.4'
8f6f989f »
2012-03-16 Updated http client libs to the latest version as dev dependencies
24 s.add_development_dependency 'patron', '>= 0.4.18' unless RUBY_PLATFORM =~ /java/
25 s.add_development_dependency 'em-http-request', '>= 1.0.2'
1d4899ae »
2012-01-22 Changed default em-http-request version dependency to >= 1.0.0. Specs…
26 s.add_development_dependency 'em-synchrony', '>= 1.0.0' if RUBY_VERSION >= "1.9"
110ca907 »
2012-02-19 Curb is not supported on JRuby
27 s.add_development_dependency 'curb', '>= 0.8.0' unless RUBY_PLATFORM =~ /java/
8f6f989f »
2012-03-16 Updated http client libs to the latest version as dev dependencies
28 s.add_development_dependency 'typhoeus', '>= 0.3.3' unless RUBY_PLATFORM =~ /java/
29 s.add_development_dependency 'excon', '>= 0.11.0'
c6ef4443 »
2011-07-30 Changed dev dependency to minitest >= 2.2.2
30 s.add_development_dependency 'minitest', '>= 2.2.2'
c70ab008 »
2011-08-09 Changed dev dependency on rdoc <=3.5 for ruby 1.8.6. rdoc >3.5 requir…
31 s.add_development_dependency 'rdoc', ((RUBY_VERSION == '1.8.6') ? '<= 3.5.0' : '>3.5.0')
ec7ec68a »
2009-11-20 Added gemspec for version 0.7.0
32
d73224f9 »
2011-05-18 Rip out jeweler and use bundler instead
33 s.files = `git ls-files`.split("\n")
34 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
35 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
36 s.require_paths = ['lib']
37 end
Something went wrong with that request. Please try again.