Skip to content
Newer
Older
100644 54 lines (45 sloc) 1.74 KB
bb63e1f Imported project to github
Bartosz Blimke authored
1 require 'rubygems'
2 require 'rake'
3
4 begin
5 require 'jeweler'
6 Jeweler::Tasks.new do |gem|
7 gem.name = "webmock"
8 gem.summary = %Q{Library for stubbing HTTP requests in Ruby.}
9 gem.description = %Q{WebMock allows stubbing HTTP requests and setting expectations on HTTP requests.}
10 gem.email = "bartosz.blimke@gmail.com"
11 gem.homepage = "http://github.com/bblimke/webmock"
12 gem.authors = ["Bartosz Blimke"]
005881c @bblimke Changed dependency on Addressable to version 2.2.2 which fixes handli…
authored
13 gem.add_dependency "addressable", ">= 2.2.2"
9c7efe3 Added depencdency on crack which is used do parse JSON and XML reques…
Bartosz Blimke authored
14 gem.add_dependency "crack", ">=0.1.7"
e4a3b6b @bblimke Changed WebMock specs to use RSpec2
authored
15 gem.add_development_dependency "rspec", ">= 2.0.0"
dde72c8 Added support for basic HTTPClient functionality. Without async reque…
Bartosz Blimke authored
16 gem.add_development_dependency "httpclient", ">= 2.1.5.2"
b04da18 @bblimke Updated development dependencies to require newest versions of suppor…
authored
17 gem.add_development_dependency "patron", ">= 0.4.9" unless RUBY_PLATFORM =~ /java/
18 gem.add_development_dependency "em-http-request", ">= 0.2.14" unless RUBY_PLATFORM =~ /java/
19 gem.add_development_dependency "curb", ">= 0.7.8" unless RUBY_PLATFORM =~ /java/
bb63e1f Imported project to github
Bartosz Blimke authored
20 end
21 Jeweler::GemcutterTasks.new
22 rescue LoadError
23 puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
24 end
25
e4a3b6b @bblimke Changed WebMock specs to use RSpec2
authored
26 require "rspec/core/rake_task"
27 RSpec::Core::RakeTask.new do |t|
28 t.rspec_opts = ["-c", "-f progress", "-r ./spec/spec_helper.rb"]
29 t.pattern = 'spec/**/*_spec.rb'
bb63e1f Imported project to github
Bartosz Blimke authored
30 end
31
32 require 'rake/testtask'
33 Rake::TestTask.new(:test) do |test|
34 test.test_files = FileList["test/**/*.rb"].exclude("test/test_helper.rb")
35 test.verbose = false
2bd65d9 Upgraded gem version to 0.7.2
Bartosz Blimke authored
36 test.warning = false
bb63e1f Imported project to github
Bartosz Blimke authored
37 end
38
39 task :spec => :check_dependencies
40
41 task :test => :check_dependencies
42
43 task :default => [:spec, :test]
44
45 require 'rake/rdoctask'
46 Rake::RDocTask.new do |rdoc|
47 version = File.exist?('VERSION') ? File.read('VERSION') : ""
48
49 rdoc.rdoc_dir = 'rdoc'
50 rdoc.title = "webmock #{version}"
51 rdoc.rdoc_files.include('README*')
52 rdoc.rdoc_files.include('lib/webmock/webmock.rb')
53 end
Something went wrong with that request. Please try again.