Skip to content
Browse files

Added guard to Rakefile to ensure a release is built on ruby 1.8

  • Loading branch information...
1 parent 5ecbc8d commit e0218c81f22c219dac0cdfe72dc621606d5e4303 @bblimke committed Jan 4, 2012
Showing with 7 additions and 0 deletions.
  1. +7 −0 Rakefile
View
7 Rakefile
@@ -56,3 +56,10 @@ RDoc::Task.new do |rdoc|
rdoc.rdoc_files.include('README*')
rdoc.rdoc_files.include('lib/webmock/webmock.rb')
end
+
+
+task :require_ruby_18 do
+ raise "This must be run on Ruby 1.8" unless RUBY_VERSION =~ /^1\.8/
+end
+
+task :release => [:require_ruby_18]

0 comments on commit e0218c8

Please sign in to comment.
Something went wrong with that request. Please try again.