Skip to content
This repository

May 12, 2012

  1. Bartosz Blimke

    webmock/rspec checks whether rspec/expectations is already loaded by …

    …checking if RSpec::Expectations::ExpectationNotMetError is defined. This is required for compatibility with RSpec 2.10.0.
    authored

Mar 16, 2012

  1. Bartosz Blimke

    Updated http client libs to the latest version as dev dependencies

    authored

Feb 19, 2012

  1. Bartosz Blimke

    Curb is not supported on JRuby

    authored
  2. Bartosz Blimke

    Updated dependency on Addressable to version >= 2.2.7 to handle neste…

    …d hash query values. I.e. `?one[two][three][]=four&one[two][three][]=five`
    authored

Feb 05, 2012

  1. Myron Marston

    Update RSpec dependency to 2.8.

    2.8 includes the ability to pass arguments to `include_context`, which we need to clean up some of the shared example conditionals.
    myronmarston authored

Feb 03, 2012

  1. Dimitrij Denissenko

    Added support for Excon

    dim authored

Jan 22, 2012

  1. Bartosz Blimke

    Typhoeus is a development dependency but not in JRuby

    authored
  2. Bartosz Blimke

    Patron is a development dependency but not in JRuby

    authored
  3. Bartosz Blimke

    Changed default em-http-request version dependency to >= 1.0.0. Specs…

    … against version 0.3.0 run on travis too.
    authored
  4. Bartosz Blimke

    Fixed compatibility with Curb >= 0.7.16 This breaks compatibility wit…

    …h Curb =< 0.7.15
    authored
  5. Bartosz Blimke

    Upgraded dev dependencies: Typhoeus to 0.3.0 and HTTPClient to 2.2.4

    authored
  6. Bartosz Blimke

    Upgraded dev dependencies to lastest Patron 0.4.17 and updated patron…

    … adapter spec to match changes in behaviour.
    authored

Nov 18, 2011

  1. Myron Marston

    Lock to a curb version that doesn't have double-request problems.

    Curb 0.7.16 causes 16 tests to fail.  Curb 0.7.15 doesn't.  This
    should be fixed at some point, but for now to get the build green
    so I can work on other things, I'm locking to 0.7.15.
    
    See issue #136 for more info.
    myronmarston authored

Aug 27, 2011

  1. Bartosz Blimke

    Upgraded Patron to version 0.4.15 as a development dependency

    authored

Aug 23, 2011

  1. Bartosz Blimke

    Run WebMock specs against both EM-HTTP-Request 0.3 and EM-HTTP-Reques…

    …t 1.0 with EM-Synchrony on Ruby > 1.9.2 on Travis CI
    authored

Aug 09, 2011

  1. Bartosz Blimke

    Added Typhoeus to development dependencies

    authored
  2. Bartosz Blimke

    Changed dev dependency on rdoc <=3.5 for ruby 1.8.6. rdoc >3.5 requir…

    …es Ruby >= 1.8.7
    authored

Aug 08, 2011

  1. Bartosz Blimke

    Added rdoc as dev dependency so that travis can handle rake tasks

    authored

Jul 30, 2011

  1. Bartosz Blimke

    Switched back default development dependency to em-http-request 0.x, …

    …until em-http-request 1.0 gets stable.
    authored
  2. Bartosz Blimke

    Merge remote branch 'sdhull/master' into em-http-request_1_0_support

    authored
  3. Bartosz Blimke

    Changed dev dependency to minitest >= 2.2.2

    authored

Jun 12, 2011

  1. pete higgins

    Add minitest as dev dependency.

    phiggins authored

Jun 10, 2011

  1. Steve

    More progress toward updating em-http-request (WIP)

    sdhull authored

May 18, 2011

  1. James Conroy-Finn

    Remove RUBY_PLATFORM conditional from gemspec

    This conditional is of no use. The gem specification generated is not
    dynamic and will always contain these gems. In order to support JRuby
    properly we'll need to create a separate gemspec.
    jcf authored
  2. James Conroy-Finn

    Rip out jeweler and use bundler instead

    jcf authored
  3. James Conroy-Finn

    Fix jeweler's gemspec mess

    jcf authored
  4. James Conroy-Finn

    Regenerate gemspec for version 1.6.3

    jcf authored
  5. James Conroy-Finn

    Regenerate gemspec for version 1.6.3

    jcf authored
  6. James Conroy-Finn

    Prepare for 1.6.3 release

    jcf authored
  7. pete higgins

    Bump addressable dependency to 2.2.6 to avoid problems with 2.2.5.

    Webmock doesn't work with addressable-2.2.5 and a new version, 2.2.6,
    has been released to help with this. Change Webmock's dependency to that
    version or higher.
    phiggins authored jcf committed

Jan 12, 2011

  1. Bartosz Blimke

    Updated version to 1.6.2

    authored

Jan 11, 2011

  1. Sam Stokes

    Version bump to 1.6.2.rapportive

    samstokes authored

Nov 13, 2010

  1. Bartosz Blimke

    Regenerated gemspec for version 1.6.1

    authored

Nov 12, 2010

  1. Bartosz Blimke

    Bump to version 1.6.0

    authored

Nov 11, 2010

  1. Bartosz Blimke

    Included new files in the gemspec.

    authored
Something went wrong with that request. Please try again.