'Invalid gemspec errors' during bundle #145

Closed
blaulabs opened this Issue Jan 4, 2012 · 3 comments

Comments

Projects
None yet
3 participants

blaulabs commented Jan 4, 2012

Since new version of 1.7.9 I get the error during bundle:

Invalid gemspec in [/home/bamboo/blau-gemcache/jruby/1.8/specifications/webmock-1.7.9.gemspec]: Illformed requirement ["#<YAML::Yecht::DefaultKey:0x5dfd35> 0.7.15"]

This issue does not happen under mri 1.9.3 and rubygems version 1.8.10, but I can reproduce it with jruby-1.6.2 and mri 1.8.7.

Collaborator

myronmarston commented Jan 4, 2012

@bblimke -- this tends to happen when you build the gem on a ruby interpreter that has psych installed (i.e. 1.9.2 or 1.9.3). I've done this a couple times with VCR, and for this reason, I've got a guard to ensure I always build VCR on 1.8.7. RSpec has something similar.

So...my suggestion is to yank 1.7.9, and then build 1.7.10 on 1.8.7 and release it.

Owner

bblimke commented Jan 4, 2012

Thanks Myron. I didn't know about this issue. 1.7.10 is released now.

@bblimke bblimke closed this Jan 4, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment