Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Hooking Typhoeus without need #222

Closed
t3hk0d3 opened this Issue · 1 comment

1 participant

@t3hk0d3
/home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/http_lib_adapters/typhoeus_hydra_adapter.rb:41:in `remove_after_request_callback': undefined method `global_hooks' for Typhoeus::Hydra:Class (NoMethodError)
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/http_lib_adapters/typhoeus_hydra_adapter.rb:23:in `disable!'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/webmock.rb:39:in `block in enable!'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/http_lib_adapters/http_lib_adapter_registry.rb:16:in `each'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/http_lib_adapters/http_lib_adapter_registry.rb:16:in `each_adapter'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/webmock.rb:38:in `enable!'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/webmock.rb:123:in `<module:WebMock>'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/webmock.rb:1:in `<top (required)>'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock.rb:48:in `<top (required)>'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:55:in `require'
    from /home/t3hk0d3/.rvm/gems/ruby-1.9.3-p194/gems/webmock-1.8.11/lib/webmock/test_unit.rb:2:in `<top (required)>'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `require'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
    from /home/t3hk0d3/projects/vod_tools/test/test_helper.rb:4:in `<top (required)>'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /home/t3hk0d3/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from test/vod_tools/xml_importer_test.rb:1:in `<main>'

Typhoeus gem is not used at all (not in Gemfile nor gemspec)

@t3hk0d3

Well, updating to 1.9.0 solve this issue.

@t3hk0d3 t3hk0d3 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.