Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Typhoeus 0.5.4 fails with master #239

Closed
i0rek opened this Issue Jan 11, 2013 · 7 comments

Comments

Projects
None yet
2 participants
Contributor

i0rek commented Jan 11, 2013

Hey @bblimke,

there are failing specs and I'm not sure what to do about it: https://gist.github.com/4514777. What do you suggest? Will provide a pull request!

Owner

bblimke commented Jan 12, 2013

Hey @i0rek

Has anything changed in Typhoeus recently? Are status codes now integer instead of string?

Contributor

i0rek commented Jan 12, 2013

Yes they are now forced to integers. It wasn't specified before and I felt bad about it. I even think there were more webmock errors b/c of that before.

Owner

bblimke commented Jan 12, 2013

Ok, thanks for update. Typhoeus adapter needs to be adjusted then. I'll try to do it next week unless you submit a pull request before.

Contributor

i0rek commented Jan 12, 2013

@bblimke It seems a bit tricky. When I force the code to be a string(https://github.com/bblimke/webmock/blob/master/lib/webmock/http_lib_adapters/typhoeus_hydra_adapter.rb#L76) I fix the first error and get another one. See the updated gist. I would happily provide a PR, but I'm not sure howto fix that atm.

Owner

bblimke commented Jan 12, 2013

It looks like this spec is wrong. Status code in webmock should be an integer. I think this line is wrong https://github.com/bblimke/webmock/blob/master/spec/acceptance/shared/callbacks.rb#L71

I will have a look later.

Owner

bblimke commented Feb 17, 2013

@i0rek I guess this one can be closed now?

Contributor

i0rek commented Feb 17, 2013

Yes.

@bblimke bblimke closed this Feb 17, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment