Excon version warning #347

daniel opened this Issue Dec 18, 2013 · 9 comments

5 participants


I get the warning "You are using Excon 0.25.3. WebMock supports version >= 0.27.5.".

In the gemspec the version specified is ">= 0.22.0", but in excon_adapter.rb you check for '0.27.5'.


Thanks for reporting that. Excon changes too fast :)
If you have to use 0.25.3, WebMock 1.14 is compatible with it.


I also noticed this today. Can you update the gemspec?

@bblimke bblimke pushed a commit that closed this issue Jan 16, 2014
@ixti ixti Bump minimal version of excon to 0.27.5
Resolves #347
@bblimke bblimke closed this in b4f7ca4 Jan 16, 2014

I still have this issue...

webmock (1.21.0)
excon (0.45.3, 0.13.4)

How to make webmock use excon 0.45.3 and not 0.13.4?


@rafaelcgo what issue exactly do you have?

WebMock will use whatever version of excon you have loaded. Just load 0.45.3


@rafaelcgo I suggest either delete 0.13.4 or use bundler.


I'm using bundler. I have a Rails app.
The problem is that I have an old version of fog (1.3.1) and it is requiring excon 0.13.4.

The only way is to update fog to a version that requires excon '0.27.5' or higher?


@rafaelcgo unfortunately yes. You can't have two different versions of same gem loaded at the same time.


@ixti Got it! Thanks


@ixti thank you for clarifying that :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment