I get the warning "You are using Excon 0.25.3. WebMock supports version >= 0.27.5.".
In the gemspec the version specified is ">= 0.22.0", but in excon_adapter.rb you check for '0.27.5'.
Thanks for reporting that. Excon changes too fast :)
If you have to use 0.25.3, WebMock 1.14 is compatible with it.
I also noticed this today. Can you update the gemspec?
Bump minimal version of excon to 0.27.5
I still have this issue...
excon (0.45.3, 0.13.4)
How to make webmock use excon 0.45.3 and not 0.13.4?
@rafaelcgo what issue exactly do you have?
WebMock will use whatever version of excon you have loaded. Just load 0.45.3
@rafaelcgo I suggest either delete 0.13.4 or use bundler.
I'm using bundler. I have a Rails app.
The problem is that I have an old version of fog (1.3.1) and it is requiring excon 0.13.4.
The only way is to update fog to a version that requires excon '0.27.5' or higher?
@rafaelcgo unfortunately yes. You can't have two different versions of same gem loaded at the same time.
@ixti Got it! Thanks
@ixti thank you for clarifying that :)