Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Testsuite fails with Ruby 1.9 #7

Closed
Flameeyes opened this Issue Jan 4, 2010 · 1 comment

Comments

Projects
None yet
2 participants

Loaded suite /usr/lib64/ruby19/gems/1.9.1/gems/rake-0.8.7/lib/rake/rake_test_loader
Started
F....

  1. Failure:
    test_error_on_non_stubbed_request(TestWebMock)
    [/var/tmp/portage/dev-ruby/webmock-0.8.0/work/all/webmock-0.8.0/test/test_helper.rb:12:in assert_fail' /var/tmp/portage/dev-ruby/webmock-0.8.0/work/all/webmock-0.8.0/test/test_webmock.rb:36:intest_error_on_non_stubbed_request']:
    <"Real HTTP connections are disabled. Unregistered request: GET http://www.example.net/"> expected but was
    <"Real HTTP connections are disabled. Unregistered request: GET http://www.example.net/ with headers {'User-Agent'=>'Ruby'}">

diff:
? Real HTTP connections are disabled. Unregistered request: GET http://www.example.net/ with headers {'User-Agent'=>'Ruby'}

Finished in 0.09713839 seconds.

5 tests, 6 assertions, 1 failures, 0 errors, 0 pendings, 0 omissions, 0 notifications
80% passed
rake aborted!
Command failed with status (1): [/usr/bin/ruby19 -I"lib" "/usr/lib64/ruby19...]

(See full trace by running task with --trace)

Owner

bblimke commented Jan 13, 2010

Fixed in master. Will be released in 0.8.1

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment