Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Bumping the crack version #247

Merged
merged 1 commit into from

2 participants

@benilovj

Security vulnerabilities have been discovered in all versions of crack <= 0.3.1. This change ensures that those versions aren't used.

@benilovj benilovj Bumping the crack version
[Security vulnerabilities have been discovered](https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately)
in <= 0.3.1 versions of crack. This change ensures that those versions
aren't used.
a9d3bc7
@bblimke
Owner

Thank you for this fix.

@bblimke bblimke closed this
@bblimke bblimke reopened this
@bblimke bblimke merged commit e1712df into bblimke:master
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 18, 2013
  1. @benilovj

    Bumping the crack version

    benilovj authored
    [Security vulnerabilities have been discovered](https://support.cloud.engineyard.com/entries/22915701-january-14-2013-security-vulnerabilities-httparty-extlib-crack-nori-update-these-gems-immediately)
    in <= 0.3.1 versions of crack. This change ensures that those versions
    aren't used.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  webmock.gemspec
View
2  webmock.gemspec
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.rubyforge_project = 'webmock'
s.add_dependency 'addressable', '>= 2.2.7'
- s.add_dependency 'crack', '>=0.1.7'
+ s.add_dependency 'crack', '>=0.3.2'
s.add_development_dependency 'rspec', '~> 2.10'
s.add_development_dependency 'httpclient', '>= 2.2.4'
Something went wrong with that request. Please try again.