Permalink
Browse files

Resolved madplay error 'CPU you selected does not support x86-64' on …

…10.6 i5 machines

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
  • Loading branch information...
1 parent 77a8b43 commit a0a1d73d845fcf83e8b01c65afe4820ab78fc76e bkonkle committed with adamv Aug 19, 2010
Showing with 4 additions and 1 deletion.
  1. +4 −1 Library/Formula/madplay.rb
@@ -16,7 +16,10 @@ def patches
end
def install
- system "./configure", "--prefix=#{prefix}", "--disable-debug", "--disable-dependency-tracking"
+ configure_flags = ["--prefix=#{prefix}", "--disable-debug", "--disable-dependency-tracking"]
+ # Avoid "error: CPU you selected does not support x86-64 instruction set"
+ configure_flags << "--build=x86_64" if Hardware.is_64_bit? and MACOS_VERSION >= 10.6
+ system "./configure", *configure_flags
system "make install"
end
end

0 comments on commit a0a1d73

Please sign in to comment.