Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Update .htaccess files for Apache 2.4+ #1631

Closed
webspy opened this Issue Jul 17, 2012 · 0 comments

Comments

Projects
None yet
2 participants

webspy commented Jul 17, 2012

In Apache 2.4+ the Deny directive is no longer available unless access_compat_module is enabled. Because of that the current .htaccess files used in certain CodeIgniter directories trigger 500 Internal Server Error when processed.

A possible update could be:

<IfModule authz_core_module>
    Require all denied
</IfModule>
<IfModule access_compat_module>
    Deny from all
</IfModule>

@narfbg narfbg added a commit that referenced this issue Jul 17, 2012

@narfbg narfbg Merge pull request #1633 from vlakoff/htaccess
Improve the solution for issue #1631
795b2b3

@nonchip nonchip pushed a commit to nonchip/CodeIgniter that referenced this issue Jun 29, 2013

@vlakoff vlakoff Improve the solution for issue #1631
.htaccess directives compatible with both Apache 2.2 and 2.4
53c1b14

@nonchip nonchip pushed a commit to nonchip/CodeIgniter that referenced this issue Jun 29, 2013

@narfbg narfbg Merge pull request #1633 from vlakoff/htaccess
Improve the solution for issue #1631
1a80f47
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment