Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Obsolete version of system/core/Input.php in 2.1.3 #1861

Closed
khromov opened this Issue Oct 8, 2012 · 2 comments

Comments

Projects
None yet
3 participants

khromov commented Oct 8, 2012

Release of 2.1.3 seems to have an obsolete version of system/core/Input.php

You can check the diffs of the file between 2.1.2 and 2.1.3 - the file is very different in 2.1.3 and it is missing some sanity checks.

The file in 2.1.3 also shows compatibility with "PHP 5.1.6" as opposed to "PHP 5.2.4" for the latest commit.

Not sure why this happened but it should be investigated if other core files are affected.

Are you sure you're comparing 2.1.2 and 2.1.3? I see 14 differences in FileMerge.app, and it matches what the changelog says was fixed (fixes in CI_Input::ip_address()). Only 3.0-dev has requirements of 5.2.4 (which is what the master/develop branches have right now), 2.1.3 should still be 5.1.6.

Contributor

narfbg commented Oct 9, 2012

There's nothing wrong with it.

@narfbg narfbg closed this Oct 9, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment