Fixed bug for PostgreSQL driver where limit() & order_by() throws error #1133

Merged
merged 3 commits into from Mar 5, 2012

Conversation

Projects
None yet
2 participants
Contributor

SammyK commented Mar 5, 2012

PostgreSQL does not support the "LIMIT" or "ORDER BY" syntax on UPDATE or DELETE queries:

http://www.postgresql.org/docs/8.1/static/sql-update.html
http://www.postgresql.org/docs/8.1/static/sql-delete.html

So I removed it from the Postgres driver. This fix allows frameworks that run both MySQL and Postgres databases to keep the limit() & order_by() functionality for MySQL.

Contributor

narfbg commented Mar 5, 2012

Great! Can you just add a changelog entry for that?

Contributor

SammyK commented Mar 5, 2012

Done.

@narfbg narfbg added a commit that referenced this pull request Mar 5, 2012

@narfbg narfbg Merge pull request #1133 from SammyK/develop
Fixed bug for PostgreSQL driver where limit() & order_by() throws error
3018c96

@narfbg narfbg merged commit 3018c96 into bcit-ci:develop Mar 5, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment