Permalink
Browse files

Change PHP version requirement to 7.1. Fixes #847

  • Loading branch information...
lonnieezell committed Dec 21, 2017
1 parent 6fb133b commit 90a604c454aa9768ac83616c114e958a474f0309
Showing with 2 additions and 3 deletions.
  1. +0 −1 .travis.yml
  2. +1 −1 composer.json
  3. +1 −1 user_guide_src/source/intro/requirements.rst
View
@@ -1,7 +1,6 @@
language: php
php:
- 7
- 7.1
- 7.2
- nightly
View
@@ -16,7 +16,7 @@
}
},
"require": {
"php": ">=7.0",
"php": ">=7.1",

This comment has been minimized.

Show comment
Hide comment
@timothymarois

timothymarois Jan 27, 2018

Contributor

I'd like to know why we are only supporting 7.1+, what is being used that causes 7.0 to be obsolete? I read the "go php 7.1" doc and I have yet to find the "reason" behind it. All it says is, "why not?", might as well go to 7.2 while we're at it since that was just released. Unless there is a feature in CI4 that relies on 7.1 I think this is nonsense. Please explain.

@timothymarois

timothymarois Jan 27, 2018

Contributor

I'd like to know why we are only supporting 7.1+, what is being used that causes 7.0 to be obsolete? I read the "go php 7.1" doc and I have yet to find the "reason" behind it. All it says is, "why not?", might as well go to 7.2 while we're at it since that was just released. Unless there is a feature in CI4 that relies on 7.1 I think this is nonsense. Please explain.

This comment has been minimized.

Show comment
Hide comment
@timothymarois

timothymarois Jan 27, 2018

Contributor

PHP 7.0 has already given us the incredible feature upgrades that this framework relies on and supports. I would like an educated debate as to why 7.1 should be the new minimum requirement because as it stands now, I don't see any argument yet to suggest 7.1 is superior and that 7.0 is not enough to run this framework.

@timothymarois

timothymarois Jan 27, 2018

Contributor

PHP 7.0 has already given us the incredible feature upgrades that this framework relies on and supports. I would like an educated debate as to why 7.1 should be the new minimum requirement because as it stands now, I don't see any argument yet to suggest 7.1 is superior and that 7.0 is not enough to run this framework.

This comment has been minimized.

Show comment
Hide comment
@timothymarois

timothymarois Jan 27, 2018

Contributor

The article written by Tomas has no factual evidence to support the requirement other than to "just do it". That, unfortunately, is not enough.

@timothymarois

timothymarois Jan 27, 2018

Contributor

The article written by Tomas has no factual evidence to support the requirement other than to "just do it". That, unfortunately, is not enough.

This comment has been minimized.

Show comment
Hide comment
@lonnieezell

lonnieezell Jan 29, 2018

Collaborator

As a community, I think the push is a fair one. PHP7.0 was a big change in the internal code and took quite a few rapid releases to become truly stable. 7.1 builds on that so is a more secure and stable platform, theoretically.

As for CI specifically - no, we don't currently use any 7.1 features, but that allows us to. Things like nullable types and HTTP/2 server push built into cURL could prove nice. Additionally, CI4 hasn't released a true Alpha version yet. With my current workload I anticipate an Alpha release not happening until early summer. Leaving a beta or RC release not happening until end of summer at the earliest. 7.0 is already receiving security patches only and will be considered end of life at the end of 2018, just shortly after CI4 is released.

@lonnieezell

lonnieezell Jan 29, 2018

Collaborator

As a community, I think the push is a fair one. PHP7.0 was a big change in the internal code and took quite a few rapid releases to become truly stable. 7.1 builds on that so is a more secure and stable platform, theoretically.

As for CI specifically - no, we don't currently use any 7.1 features, but that allows us to. Things like nullable types and HTTP/2 server push built into cURL could prove nice. Additionally, CI4 hasn't released a true Alpha version yet. With my current workload I anticipate an Alpha release not happening until early summer. Leaving a beta or RC release not happening until end of summer at the earliest. 7.0 is already receiving security patches only and will be considered end of life at the end of 2018, just shortly after CI4 is released.

This comment has been minimized.

Show comment
Hide comment
@benedmunds

benedmunds Jan 29, 2018

Collaborator

I also agree we should go 7.1, no real concern given the release schedule of CI v PHP 7.0's EOL.

@benedmunds

benedmunds Jan 29, 2018

Collaborator

I also agree we should go 7.1, no real concern given the release schedule of CI v PHP 7.0's EOL.

This comment has been minimized.

Show comment
Hide comment
@jim-parry

jim-parry Jan 29, 2018

Collaborator

I would be fine with a minimum version of 7.2, so that we have libsodium for encryption!
7.1 as a minimum is better than 7.0 :-/

@jim-parry

jim-parry Jan 29, 2018

Collaborator

I would be fine with a minimum version of 7.2, so that we have libsodium for encryption!
7.1 as a minimum is better than 7.0 :-/

This comment has been minimized.

Show comment
Hide comment
@timothymarois

timothymarois Feb 9, 2018

Contributor

@lonnieezell Got it. Thanks for the clarification.

@timothymarois

timothymarois Feb 9, 2018

Contributor

@lonnieezell Got it. Thanks for the clarification.

"zendframework/zend-escaper": "^2.5",
"paragonie/sodium_compat": "^1.1",
"kint-php/kint": "^2.1"
@@ -2,7 +2,7 @@
Server Requirements
###################
`PHP <http://php.net/>`_ version 7.0.15 or newer is required, with the *intl* extension installed.
`PHP <http://php.net/>`_ version 7.1 or newer is required, with the *intl* extension installed. [Why 7.1](https://gophp71.org/)?
A database is required for most web application programming.
Currently supported databases are:

0 comments on commit 90a604c

Please sign in to comment.