Browse files

Move completely to bundler

  • Loading branch information...
1 parent 1f0964e commit 835a44e063ba21c34c0af5cde0ec7cc95fa87759 @EnriqueVidal EnriqueVidal committed Apr 10, 2012
Showing with 45 additions and 116 deletions.
  1. +2 −12 Gemfile
  2. +9 −9 Gemfile.lock
  3. +5 −27 Rakefile
  4. +24 −68 acl9.gemspec
  5. +3 −0 lib/acl9/version.rb
  6. +2 −0 test/test_helper.rb
View
14 Gemfile
@@ -1,14 +1,4 @@
source "http://rubygems.org"
-gem "rake"
-gem "yard"
-gem "jnunemaker-matchy", ">= 0.4.0"
-gem "be9-context", ">= 0.5.5"
-
-gem "rails", "2.3.12"
-gem "sqlite3"
-gem "jeweler"
-
-group :test do
- gem 'turn'
-end
+# Specify your gem's dependencies in csvision.gemspec
+gemspec
View
18 Gemfile.lock
@@ -1,3 +1,9 @@
+PATH
+ remote: .
+ specs:
+ acl9 (0.12.0)
+ rails (= 2.3.12)
+
GEM
remote: http://rubygems.org/
specs:
@@ -13,13 +19,8 @@ GEM
activesupport (2.3.12)
ansi (1.3.0)
be9-context (0.5.5)
- git (1.2.5)
- jeweler (1.6.4)
- bundler (~> 1.0)
- git (>= 1.2.5)
- rake
jnunemaker-matchy (0.4.0)
- rack (1.1.2)
+ rack (1.1.3)
rails (2.3.12)
actionmailer (= 2.3.12)
actionpack (= 2.3.12)
@@ -31,16 +32,15 @@ GEM
sqlite3 (1.3.5)
turn (0.8.3)
ansi
- yard (0.7.4)
+ yard (0.7.5)
PLATFORMS
ruby
DEPENDENCIES
+ acl9!
be9-context (>= 0.5.5)
- jeweler
jnunemaker-matchy (>= 0.4.0)
- rails (= 2.3.12)
rake
sqlite3
turn
View
32 Rakefile
@@ -1,40 +1,18 @@
-require 'rubygems'
+#!/usr/bin/env rake
+require 'bundler/gem_tasks'
require 'rake'
require 'rake/testtask'
+require 'yard'
desc 'Default: run tests.'
task :default => :test
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |s|
- s.name = "acl9"
- s.summary = "Yet another role-based authorization system for Rails"
- s.email = "olegdashevskii@gmail.com"
- s.homepage = "http://github.com/be9/acl9"
- s.description = "Role-based authorization system for Rails with a nice DSL for access control lists"
- s.authors = ["oleg dashevskii"]
- s.files = FileList["[A-Z]*", "{lib,test}/**/*.rb"]
- s.add_development_dependency "be9-context", ">= 0.5.5"
- s.add_development_dependency "jnunemaker-matchy", ">= 0.4.0"
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler not available. Install it with: sudo gem install jeweler"
-end
-
Rake::TestTask.new(:test) do |test|
test.libs << 'lib' << 'test'
test.pattern = 'test/**/*_test.rb'
test.verbose = false
end
-begin
- require 'yard'
-
- YARD::Rake::YardocTask.new do |t|
- t.files = ['lib/**/*.rb']
- #t.options = ['--any', '--extra', '--opts'] # optional
- end
-rescue LoadError
+YARD::Rake::YardocTask.new do |t|
+ t.files = ['lib/**/*.rb']
end
View
92 acl9.gemspec
@@ -1,76 +1,32 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.unshift File.expand_path("../lib", __FILE__)
+require "acl9/version"
Gem::Specification.new do |s|
- s.name = %q{acl9}
- s.version = "0.12.0"
+ s.authors = ["oleg dashevskii"]
+ s.email = ["olegdashevskii@gmail.com"]
+ s.description = %q{Role-based authorization system for Rails with a nice DSL for access control lists}
+ s.summary = %q{Yet another role-based authorization system for Rails}
+ s.homepage = "http://github.com/be9/acl9"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["oleg dashevskii"]
- s.date = %q{2010-11-02}
- s.description = %q{Role-based authorization system for Rails with a nice DSL for access control lists}
- s.email = %q{olegdashevskii@gmail.com}
- s.extra_rdoc_files = [
- "README.textile",
- "TODO"
- ]
- s.files = [
- "CHANGELOG.textile",
- "MIT-LICENSE",
- "README.textile",
- "Rakefile",
- "TODO",
- "VERSION.yml",
- "lib/acl9.rb",
- "lib/acl9/config.rb",
- "lib/acl9/controller_extensions.rb",
- "lib/acl9/controller_extensions/dsl_base.rb",
- "lib/acl9/controller_extensions/generators.rb",
- "lib/acl9/helpers.rb",
- "lib/acl9/model_extensions.rb",
- "lib/acl9/model_extensions/for_object.rb",
- "lib/acl9/model_extensions/for_subject.rb",
- "test/access_control_test.rb",
- "test/dsl_base_test.rb",
- "test/helpers_test.rb",
- "test/roles_test.rb",
- "test/support/controllers.rb",
- "test/support/models.rb",
- "test/support/schema.rb",
- "test/test_helper.rb"
- ]
- s.homepage = %q{http://github.com/be9/acl9}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Yet another role-based authorization system for Rails}
- s.test_files = [
- "test/helpers_test.rb",
- "test/support/schema.rb",
- "test/support/models.rb",
- "test/support/controllers.rb",
- "test/dsl_base_test.rb",
- "test/access_control_test.rb",
- "test/test_helper.rb",
- "test/roles_test.rb"
- ]
+ s.files = `git ls-files`.split($\)
+ s.executables = s.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
+ s.test_files = s.files.grep(%r{^(test|spec|features)/})
+ s.name = "acl9"
+ s.require_paths = ["lib"]
+ s.version = Acl9::VERSION
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.date = %q{2010-11-02}
+ s.extra_rdoc_files = %w/README.textile TODO/
+ s.rdoc_options = ["--charset=UTF-8"]
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<be9-context>, [">= 0.5.5"])
- s.add_development_dependency(%q<jnunemaker-matchy>, [">= 0.4.0"])
- else
- s.add_dependency(%q<be9-context>, [">= 0.5.5"])
- s.add_dependency(%q<jnunemaker-matchy>, [">= 0.4.0"])
- end
- else
- s.add_dependency(%q<be9-context>, [">= 0.5.5"])
- s.add_dependency(%q<jnunemaker-matchy>, [">= 0.4.0"])
- end
+ s.add_dependency "rails", "2.3.12"

This makes the gem only usable with rails 2.3.12 - since the instructions also talk about installing for rails 3.0 I'm assuming this is not what was intended

@EnriqueVidal
Collaborator

hmmm... I think changing this to s.add_development_dependency "rails", "2.3.12" should let the user use which ever Rails version he/she wishes. I'll make a pull request with that + other changes shortly this week. Thanks @twalpole.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+
+ s.add_development_dependency "be9-context", ">= 0.5.5"
+ s.add_development_dependency "jnunemaker-matchy", ">= 0.4.0"
+ s.add_development_dependency "rake"
+ s.add_development_dependency "yard"
+ s.add_development_dependency 'sqlite3'
+ s.add_development_dependency 'turn'
end
View
3 lib/acl9/version.rb
@@ -0,0 +1,3 @@
+module Acl9
+ VERSION = "0.12.0"
+end
View
2 test/test_helper.rb
@@ -1,3 +1,5 @@
+require 'rubygems'
+require 'bundler/setup'
require 'test/unit'
require 'context'
require 'matchy'

0 comments on commit 835a44e

Please sign in to comment.