Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

AJAX requests breaks after upgrade rails from 2.3.8. to 2.3.11 #43

Closed
aya-soft opened this Issue · 1 comment

2 participants

@aya-soft

I have role names in russian, for example:

access_control do
allow :Администратор
allow :Заказчик
allow :Исполнитель
deny anonymous
end

and after upgrade rails from 2.3.8. to 2.3.11 a became FilterSyntaxError in generators.rb only by AJAX requests here :

    def to_proc
      code = <<-RUBY
        lambda do |controller|
          unless #{allowance_expression}
            #{_access_denied}
          end
        end
      RUBY

      self.instance_eval(code, __FILE__, __LINE__)
    rescue SyntaxError
      raise FilterSyntaxError, code
    end
@smathy smathy added the wontfix label
@smathy
Collaborator

I realize that this is too old now to be of any use to the OPs, I'm just getting involved so combing the back issues. Nothing for those old versions of Rails is going to be fixed.

@smathy smathy closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.