Remove feed link generation code from the Asset class #4

beastaugh opened this Issue May 13, 2009 · 1 comment

1 participant


WordPress 2.8 includes the automatic_feed_links() function, which replicates this functionality. Tarski already uses this function if it's available, but by using it exclusively we could remove the large and hairy feeds() method from the Asset class.

This would involve dropping support for WordPress 2.7 from Tarski 2.5, although requiring the most recent version of WordPress has been usual for recent Tarski releases. An additional consideration might be that Tarski 2.4 was released over five months ago, and requiring a WordPress upgrade is not an onerous requirement since users should be upgrading anyway.


Remove TarskiAsset->feed() function. Breaks backwards compatibility with WordPress 2.7. Closed by e378d98.

@beastaugh beastaugh added a commit that referenced this issue Dec 16, 2012
@beastaugh Make screenshot bigger.
Fixes gh-4.
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment