'Update' button becomes disabled #56

Closed
channeleaton opened this Issue May 30, 2013 · 2 comments

3 participants

@channeleaton

I'm linking to a short screencast of what's going on.

Basically, the update button will disable itself after a few seconds. I'm not sure if this is a bug or feature.

http://screencast.com/t/a8gEgQpz23

@cojennin

Interesting. I haven't been able to listen to the audio yet (if there is any), but I'm going to assume that this is more of a featurey-bug. Since WP Document Revisions concerns itself with media (documents, spreadsheets, etc), it does not need to implement auto-drafts of content (the behind the scenes saving of your post text that WordPress does every once in a while). Whereas you might lose a bunch of text if you forget to hit save on a post (which is why auto-save is so important), the only time a document changes is when a new document is uploaded. So there's no real need for an auto-save.

At the same time, this is a bit of a bug because it looks like auto-save is kicking in anyway after a little while (but since the update action hasn't occurred, everything looks the same until you refresh the page). I'd like to go through the code a bit more before I leap to further conclusions, but that's what I think might be the situation in meantime. Ben might have a better explanation if he spots this.

@benbalter
Owner

Closing as stale, please feel free to reopen if this is still occurring.

@benbalter benbalter closed this Aug 2, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment