Permalink
Browse files

Upgrade to bundler 0.9

Change-Id: I0eb346eeb3d268ffb357cf08569ab6ed19dd2e9f
  • Loading branch information...
1 parent 169f486 commit 9851c53fe83e4448e8f16196444459dd7c581e0a @indirect indirect committed Feb 8, 2010
Showing with 6 additions and 10 deletions.
  1. +5 −6 Gemfile
  2. +0 −3 Rakefile
  3. +1 −1 spec/spec_helper.rb
View
11 Gemfile
@@ -1,17 +1,16 @@
-only :test do
+group :test do
gem "rake"
- gem "rspec", :require_as => "spec"
+ gem "rspec", :require => "spec"
gem "fakeweb"
gem "fakefs"
end
-only :rake do
+group :rake do
gem "jeweler"
end
gem 'highline'
-gem 'rest-client', :require_as => 'rest_client'
+gem 'rest-client', :require => 'rest_client'
gem 'json'
-disable_system_gems
-bin_path "gbin"
+source :gemcutter
View
@@ -1,6 +1,3 @@
-require 'rubygems'
-require 'rake'
-
begin
require 'jeweler'
Jeweler::Tasks.new do |gem|
View
@@ -2,7 +2,7 @@
$LOAD_PATH.unshift(File.join(File.dirname(__FILE__), '..', 'lib'))
require 'engineyard'
-Bundler.require_env :test
+Bundler.require(:default, :test)
require 'spec'
require 'spec/autorun'

0 comments on commit 9851c53

Please sign in to comment.