Permalink
Browse files

Updated the gemspec for github gem

Updated the version to 2.7
  • Loading branch information...
1 parent 7c50429 commit c0a47b0a5145c91fe610d85620295782ad91b8e7 Ari Lerner committed Oct 15, 2008
View
@@ -1,6 +1,6 @@
Gem::Specification.new do |s|
s.name = %q{poolparty}
- s.version = "0.2.6"
+ s.version = "0.2.7"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ari Lerner"]
View
@@ -8,11 +8,6 @@ o = PoolParty::Optioner.new(ARGV) do |opts, optioner|
end
load_pool(o.spec || Binary.get_existing_spec_location)
-unless o.cloudname && clouds.keys.size > 1
- @cloud = cloud(o.cloudname.downcase.to_sym)
-else
- puts "Error: You must indicate a cloud from which your instance is from"
- exit(0)
-end
+@cloud = o.cloudname ? cloud(o.cloudname) : cloud(clouds.keys.first)
-instance = @cloud.ssh_into_instance_number( o.num.to_i || 0 )
+instance = @cloud.ssh_into_instance_number( o.num.to_i || 0 ) if @cloud
@@ -24,6 +24,7 @@ def enable
has_host({:name => "#{ri.name}", :ip => ri.ip })
end
+ # -n #{parent.name}
has_cron({:command => "cloud-maintain"}) do
minute "*/5"
end
@@ -206,7 +206,7 @@ def template_directory
end
def fix_rubygems
- "echo '#{open(::File.join(template_directory, "..", "..", "gem")).read}' > /usr/bin/gem"
+ "echo '#{open(::File.join(template_directory, "gem")).read}' > /usr/bin/gem"
end
def create_local_node
@@ -21,7 +21,7 @@ def has_git_repos
exec({:name => "git-#{name}"}) do
command @parent.user ? "git clone #{@parent.user}@#{@parent.source} #{@parent.path}" : "git clone #{@parent.source} #{@parent.path}"
- cwd "#{::File.dirname(@parent.path) if ::File.dirname(@parent.path)}"
+ cwd "#{::File.dirname(@parent.path) if @parent.path}"
creates "#{@parent.path}/.git"
end
View
@@ -2,7 +2,7 @@ module PoolParty
module VERSION #:nodoc:
MAJOR = 0
MINOR = 2
- TINY = 6
+ TINY = 7
STRING = [MAJOR, MINOR, TINY].join('.')
end
View
@@ -1,6 +1,6 @@
Gem::Specification.new do |s|
s.name = %q{poolparty}
- s.version = "0.2.6"
+ s.version = "0.2.7"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Ari Lerner"]
View
@@ -34,7 +34,7 @@
<h1>PoolParty</h1>
<div id="version" class="clickable" onclick='document.location = "http://rubyforge.org/projects/poolparty"; return false'>
<p>Get Version</p>
- <a href="http://rubyforge.org/projects/poolparty" class="numbers">0.2.6</a>
+ <a href="http://rubyforge.org/projects/poolparty" class="numbers">0.2.7</a>
</div>
<h1>&#8216;Easy cloud computing&#8217;</h1>
<h2>What</h2>

0 comments on commit c0a47b0

Please sign in to comment.