Reducer no longer works on 1.9 #1

Closed
mkaito opened this Issue Sep 16, 2009 · 1 comment

Comments

Projects
None yet
3 participants
@mkaito

mkaito commented Sep 16, 2009

This is just a single example. Just run the specs to get more.

/[:stuff:]/.gen
TypeError: [:stuff] is not a symbol
from /usr/local/lib/ruby1.9/gems/1.9.1/gems/randexp-0.1.5/lib/randexp/reducer.rb:97:in randgen' from /usr/local/lib/ruby1.9/gems/1.9.1/gems/randexp-0.1.5/lib/randexp/reducer.rb:20:inrandom'
from /usr/local/lib/ruby1.9/gems/1.9.1/gems/randexp-0.1.5/lib/randexp/reducer.rb:4:in reduce' from /usr/local/lib/ruby1.9/gems/1.9.1/gems/randexp-0.1.5/lib/randexp.rb:9:inreduce'
from /usr/local/lib/ruby1.9/gems/1.9.1/gems/randexp-0.1.5/lib/randexp/core_ext/regexp.rb:3:in generate' from (irb):5 from /usr/local/bin/irb:12:in

'

@RipTheJacker

This comment has been minimized.

Show comment Hide comment
@RipTheJacker

RipTheJacker Dec 24, 2010

All specs are passing in 1.9.2 currently.

All specs are passing in 1.9.2 currently.

@benburkert benburkert closed this Apr 11, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment