Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

gem created

  • Loading branch information...
commit 828c23e985cd5a4e1de19be6c98aee2d5aee2229 1 parent 258ea94
@bendangelo authored
View
7 .gitignore
@@ -1 +1,6 @@
-Thumbs.db
+Thumbs.db
+*.gem
+.bundle
+Gemfile.lock
+pkg/*
+.redcar
View
4 Gemfile
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in entityjs.gemspec
+gemspec
View
1  Rakefile
@@ -0,0 +1 @@
+require "bundler/gem_tasks"
View
3  bin/entityjs
@@ -0,0 +1,3 @@
+#!/usr/bin/env ruby
+
+puts 'running entityjs....'
View
18 ent.rb
@@ -1,18 +0,0 @@
-=begin
-
-Simple game helper for developing Entity games.
-
-ent new mygame - will create a new game in /games
-ent comp mycomp - will create a new component in the current folder
-ent min mygame - will minify all code into one file
-
-=end
-
-case ARGV[0]
- when 'new'
-
- when 'comp'
-
- when 'min'
-
-end
View
25 entityjs.gemspec
@@ -0,0 +1,25 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "entityjs/version"
+
+Gem::Specification.new do |s|
+ s.name = "entityjs"
+ s.version = Entityjs::VERSION
+ s.authors = ["Ben D'Angelo"]
+ s.email = ["ben.dangelo2@gmail.com"]
+ s.homepage = "http://entityjs.com"
+ s.summary = %q{A HTML5 Javascript game engine.}
+ s.description = %q{A HTML5 Javascript game engine.}
+
+ s.rubyforge_project = "entityjs"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+
+ # specify any dependencies here; for example:
+ # s.add_development_dependency "rspec"
+ # s.add_runtime_dependency "rest-client"
+ s.add_runtime_dependency 'uglifier'
+end
View
5 lib/entityjs.rb
@@ -0,0 +1,5 @@
+require "entityjs/version"
+
+module Entityjs
+ # Your code goes here...
+end
View
9 lib/entityjs/game.rb
@@ -0,0 +1,9 @@
+module Entityjs
+
+ class Game
+
+
+
+ end
+
+end
View
3  lib/entityjs/version.rb
@@ -0,0 +1,3 @@
+module Entityjs
+ VERSION = "0.2.2"
+end
Please sign in to comment.
Something went wrong with that request. Please try again.