Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

executable file 36 lines (30 sloc) 1.548 kb
#!/usr/bin/env ruby -rubygems
# -*- encoding: utf-8 -*-
Gem::Specification.new do |gem|
gem.version = File.read('VERSION').chomp
gem.date = File.mtime('VERSION').strftime('%Y-%m-%d')
gem.name = 'rdf'
gem.homepage = 'http://ruby-rdf.github.com/rdf'
gem.license = 'Public Domain' if gem.respond_to?(:license=)
gem.summary = 'A Ruby library for working with Resource Description Framework (RDF) data.'
gem.description = 'RDF.rb is a pure-Ruby library for working with Resource Description Framework (RDF) data.'
gem.rubyforge_project = 'rdf'
gem.authors = ['Arto Bendiken', 'Ben Lavender', 'Gregg Kellogg']
gem.email = 'public-rdf-ruby@w3.org'
gem.platform = Gem::Platform::RUBY
gem.files = %w(AUTHORS CREDITS README UNLICENSE VERSION bin/rdf etc/doap.nt) + Dir.glob('lib/**/*.rb')
gem.bindir = %q(bin)
gem.executables = %w(rdf)
gem.default_executable = gem.executables.first
gem.require_paths = %w(lib)
gem.extensions = %w()
gem.test_files = %w()
gem.has_rdoc = false
gem.required_ruby_version = '>= 1.8.1'
gem.requirements = []
gem.add_runtime_dependency 'addressable', '>= 2.2.6'
gem.add_development_dependency 'yard', '>= 0.7.5'
gem.add_development_dependency 'rdf-spec', '~> 0.3.8'
gem.add_development_dependency 'rspec', '>= 2.8.0'
gem.post_install_message = nil
end
Jump to Line
Something went wrong with that request. Please try again.