Permalink
Browse files

No need for a separate 'ruby' dep using #requires_when_unmet now we'r…

…e using the 'bin' template.
  • Loading branch information...
1 parent e8f259f commit 0596dd3554e6d062ef6e73c2fe64e965bd527cf2 @benhoskings committed May 19, 2012
Showing with 2 additions and 9 deletions.
  1. +2 −9 deps/ruby.rb
View
@@ -1,16 +1,9 @@
-dep 'ruby' do
- met? {
- in_path? ['ruby >= 1.8.6', 'irb']
- }
- requires_when_unmet 'ruby.bin'
-end
-
-dep 'ruby.bin' do
+dep 'ruby', :template => 'bin' do
installs {
via [:lenny, :hardy, :lucid], %w[ruby irb ruby1.8-dev libopenssl-ruby]
via :apt, %w[ruby ruby1.8-dev]
via :yum, %w[ruby ruby-irb]
otherwise 'ruby'
}
- provides %w[ruby irb]
+ provides 'ruby >= 1.8.6', 'irb'
end

0 comments on commit 0596dd3

Please sign in to comment.