messengerjs-rails is a Rails (3.1 and above) wrapper for Messenger javascript library.
Ruby
Switch branches/tags
Nothing to show
Latest commit d1182a5 Mar 21, 2014 Ben Song Ben Song Bump to 1.4.1
Permalink
Failed to load latest commit information.
lib Bump to 1.4.1 Mar 21, 2014
vendor/assets Bump to 1.4.1 Mar 21, 2014
.gitignore first commit Mar 26, 2013
Gemfile first commit Mar 26, 2013
MIT-LICENSE first commit Mar 26, 2013
README.md Bump to 1.4.1 Mar 21, 2014
Rakefile first commit Mar 26, 2013
messengerjs-rails.gemspec Bump to 1.4.1 Mar 21, 2014

README.md

messengerjs-rails

messengerjs-rails is a Rails (3.1 and above) wrapper for Messenger javascript library.

Messenger

  • Show messages in your app.
  • Wrap AJAX requests with progress, success and error messages, and add retry to your failed requests.
  • Add actions (undo, cancel, etc.) to your messages.

Messenger

Demo and Usage

Docs

Requirement/Dependency:

  1. jQuery

  2. Plays well with, but doesn't require, Bootstrap

Installation

Add the following to your gemfile:

gem "messengerjs-rails", "~> 1.4.1"

Add the following directive to your application.coffee / application.js:

//= require jquery-rails
*
*
//= require messenger
//= require messenger-theme-future

Add the following directive to your application.scss / application.css. There are four themes/styles provided (future, air, block and ice), change required stylesheet as needed.

*= require messenger
  *= require messenger-spinner
  *= require messenger-theme-future

Versioning

Every attempt is made to mirror the currently shipping Messenger version number wherever possible. The major, minor, and patch version numbers will always represent the Messenger version.

Contributing

Feel free to open an issue ticket if you find something that could be improved.

Acknowledgements

Copyright Ben Song(zbin.song@gmail.com), released under the MIT License.