Fixed Jruby build #1

Merged
merged 2 commits into from Nov 2, 2011

3 participants

@taylor

NOTE:
* Niceogiri is not compatible with 1.5.x at this time because of all
of the changes from 1.4.x to 1.5.
* Bundler needs to be installed under jruby with 1.9 mode off (no * --1.9)

-- Lance and Taylor

@taylor taylor Nokogiri 1.4.7 required to fix XML namespace issues with jruby
  NOTE:
    * Niceogiri is not compatible with 1.5.x at this time because of all
      of the changes from 1.4.x to 1.5.
    * Bundler needs to be installed under jruby with 1.9 mode off (no * --1.9)

  -- Lance and Taylor
35b067f
@benlangfeld
Owner

So this is because Nokogiri 1.4.x uses libxml2 via FFI, rather than Java's XML libs. We need to support Nokogiri 1.5 imo.

@taylor

Yes it was FFI vs Java XML. When the environment was set to use Nokogiri 1.4.7 java with the Java XML libs everything worked.

1.5 has had a ton of changes. The first non-beta of 1.5 came out on July 1st which was also the day 1.4.7 was released. I assume the 1.4.x branch will be maintained for a while.

@benlangfeld benlangfeld merged commit 6675cdb into benlangfeld:master Nov 2, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment